Annoyances with octave 6.0 (editor and others)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Annoyances with octave 6.0 (editor and others)

José Abílio Matos
Hi,
  I am writing this in order to understand if this is a known bug, and if not
to submit a bug in Savannah.

  The background, I am using octave in Fedora 32, compiled using gcc 10 and qt
5.13.2 among others.

  My first annoyance is that sometimes is a if the editor looses the focus, I
do not know where the cursor is. I do not know I get in this state. The work
around is simple, changing to the command line and back gets the focus again.

  Sometimes the shortcuts do not work, e.g. Ctr+S to save or copy or paste....
Again the solution is to use the mouse, clicking over the document and then
all works again. It is weird... :-)

  Another small annoyance, this time not related with the Editor is that when
working with namespaces I need to quit octave and restart it so that a change
in the folder structure is reflected in the namespace.

As an example suppose that suppose that I have a structure like this:

+dir1/+dir2/file1.m
+dir1/+dir3/file2.m
+dir1/file3.m

If add another file or directory to this structure, let us says +dir1/file4.m
and I refer to dir1.file4 Octave throws an error complaining that dir1.file4
does not exists.

Restarting and starting over fixes this.

Is there any workaround? E.g. when using classes and touching a classdef file
issuing "clear classes" allows the changes to be known.

Thank you for the amazing work done on octave.

Best regards,
--
José Matos



Reply | Threaded
Open this post in threaded view
|

Re: Annoyances with octave 6.0 (editor and others)

Torsten Lilge
On Wed, 2020-04-29 at 17:27 +0100, José Abílio Matos wrote:

> Hi,
>   I am writing this in order to understand if this is a known bug, and
> if not
> to submit a bug in Savannah.
>
>   The background, I am using octave in Fedora 32, compiled using gcc
> 10 and qt
> 5.13.2 among others.
>
>   My first annoyance is that sometimes is a if the editor looses the
> focus, I
> do not know where the cursor is. I do not know I get in this state.
> The work
> around is simple, changing to the command line and back gets the focus
> again.
>
>   Sometimes the shortcuts do not work, e.g. Ctr+S to save or copy or
> paste....
> Again the solution is to use the mouse, clicking over the document and
> then
> all works again. It is weird... :-)
>
>

Hi José,

I would like tor reply to the first annoyance you are experiencing.
There are already bug reports on the focus and shortcut issue (where the
latter is probably related to the focus issue). Interestingly you are
also using qt5.13.x which is the case on many (all?) systems where the
issues came up.

If you are able to robustly reproduce the lost of focus, please add a
comment to the related bug reports

   1. Focus: https://savannah.gnu.org/bugs/?57635
   2. Shortcuts: https://savannah.gnu.org/bugs/?57969

Torsten