Can't install dicom package (0.1.1 and 0.1.2 (user version)) in octave 4.0.2 and ubuntu 14.0

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't install dicom package (0.1.1 and 0.1.2 (user version)) in octave 4.0.2 and ubuntu 14.0

Mario Briseño

I've been trying a lot of things, even changing from w10 to ubuntu asa virtual
machine. So, I'm not a Linux user.
NO problem installing octave, but when I try to install dicom at octave CLI i
have this errors:

pkg install dicom-0.1.1.tar.gz
dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
directory
compilation terminated.
make: *** [dicominfo.o] Error 1
make: *** Waiting for unfinished jobs....
dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
directory
compilation terminated.
make: *** [dicomdict.o] Error 1
dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No such file or
directory
compilation terminated.
make: *** [dicomread.oct] Error 1
make: Entering directory '/tmp/oct-gASVrN/dicom/src'
mkoctfile -c  -g dicominfo.cpp
mkoctfile -c  -g dicomdict.cpp
mkoctfile  -L/usr/local/lib -lgdcmcharls  -lgdcmjpeg8 -lgdcmjpeg12
-lgdcmjpeg16 -lgdcmCommon -lgdcmDICT -lgdcmDSED -lgdcmIOD -lgdcmMSFF   -g
dicomread.cpp
Makefile:51: recipe for target 'dicominfo.o' failed
Makefile:57: recipe for target 'dicomdict.o' failed
Makefile:44: recipe for target 'dicomread.oct' failed
make: Leaving directory '/tmp/oct-gASVrN/dicom/src'

pkg: error running `make' for the dicom package.
error: called from 'configure_make' in file
/usr/share/octave/4.0.2/m/pkg/private/configure_make.m near line 96, column 9

I've installed the latest versions of cmake, installed the gdcm 2.6 package
and followed this page:
http://gdcm.sourceforge.net/wiki/index.php/Compilation

As I've said, I have just 5 hours using Ubuntu for the first time.

I'd appreciate your help!

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Can't install dicom package (0.1.1 and 0.1.2 (user version)) in octave 4.0.2 and ubuntu 14.0

andy buckle


On 27 Jan 2017 11:27 p.m., "Mario Briseño" <[hidden email]> wrote:

I've been trying a lot of things, even changing from w10 to ubuntu asa virtual
machine. So, I'm not a Linux user.
NO problem installing octave, but when I try to install dicom at octave CLI i
have this errors:

pkg install dicom-0.1.1.tar.gz
dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
directory
compilation terminated.
make: *** [dicominfo.o] Error 1
make: *** Waiting for unfinished jobs....
dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
directory
compilation terminated.
make: *** [dicomdict.o] Error 1
dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No such file or
directory
compilation terminated.
make: *** [dicomread.oct] Error 1
make: Entering directory '/tmp/oct-gASVrN/dicom/src'
mkoctfile -c  -g dicominfo.cpp
mkoctfile -c  -g dicomdict.cpp
mkoctfile  -L/usr/local/lib -lgdcmcharls  -lgdcmjpeg8 -lgdcmjpeg12
-lgdcmjpeg16 -lgdcmCommon -lgdcmDICT -lgdcmDSED -lgdcmIOD -lgdcmMSFF   -g
dicomread.cpp
Makefile:51: recipe for target 'dicominfo.o' failed
Makefile:57: recipe for target 'dicomdict.o' failed
Makefile:44: recipe for target 'dicomread.oct' failed
make: Leaving directory '/tmp/oct-gASVrN/dicom/src'

pkg: error running `make' for the dicom package.
error: called from 'configure_make' in file
/usr/share/octave/4.0.2/m/pkg/private/configure_make.m near line 96, column 9

I've installed the latest versions of cmake, installed the gdcm 2.6 package
and followed this page:
http://gdcm.sourceforge.net/wiki/index.php/Compilation

As I've said, I have just 5 hours using Ubuntu for the first time.

I'd appreciate your help!

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave



Find you install the dependency, gdcm?

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Can't install dicom package (0.1.1 and 0.1.2 (user version)) in octave 4.0.2 and ubuntu 14.0

Pablo Fernandez


El 28/01/17 a las 07:47, Andy Buckle escribió:

>
>
> On 27 Jan 2017 11:27 p.m., "Mario Briseño" <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>     I've been trying a lot of things, even changing from w10 to ubuntu
>     asa virtual
>     machine. So, I'm not a Linux user.
>     NO problem installing octave, but when I try to install dicom at
>     octave CLI i
>     have this errors:
>
>     pkg install dicom-0.1.1.tar.gz
>     dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
>     directory
>     compilation terminated.
>     make: *** [dicominfo.o] Error 1
>     make: *** Waiting for unfinished jobs....
>     dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
>     directory
>     compilation terminated.
>     make: *** [dicomdict.o] Error 1
>     dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No
>     such file or
>     directory
>     compilation terminated.
>     make: *** [dicomread.oct] Error 1
>     make: Entering directory '/tmp/oct-gASVrN/dicom/src'
>     mkoctfile -c  -g dicominfo.cpp
>     mkoctfile -c  -g dicomdict.cpp
>     mkoctfile  -L/usr/local/lib -lgdcmcharls  -lgdcmjpeg8 -lgdcmjpeg12
>     -lgdcmjpeg16 -lgdcmCommon -lgdcmDICT -lgdcmDSED -lgdcmIOD
>     -lgdcmMSFF   -g
>     dicomread.cpp
>     Makefile:51: recipe for target 'dicominfo.o' failed
>     Makefile:57: recipe for target 'dicomdict.o' failed
>     Makefile:44: recipe for target 'dicomread.oct' failed
>     make: Leaving directory '/tmp/oct-gASVrN/dicom/src'
>
>     pkg: error running `make' for the dicom package.
>     error: called from 'configure_make' in file
>     /usr/share/octave/4.0.2/m/pkg/private/configure_make.m near line 96,
>     column 9
>
>     I've installed the latest versions of cmake, installed the gdcm 2.6
>     package
>     and followed this page:
>     http://gdcm.sourceforge.net/wiki/index.php/Compilation
>     <http://gdcm.sourceforge.net/wiki/index.php/Compilation>
>
>     As I've said, I have just 5 hours using Ubuntu for the first time.
>
>     I'd appreciate your help!
>
>     _______________________________________________
>     Help-octave mailing list
>     [hidden email] <mailto:[hidden email]>
>     https://lists.gnu.org/mailman/listinfo/help-octave
>     <https://lists.gnu.org/mailman/listinfo/help-octave>
>
>
>
> Find you install the dependency, gdcm?
>
>
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://lists.gnu.org/mailman/listinfo/help-octave


I am not a dicom user but I am trying to help to diagnose the problem.
I have recently installed ubuntu 16.04 and I have just installed octave
from the ubuntu repositories:

octave:3> ver
----------------------------------------------------------------------
GNU Octave Version: 4.0.0
GNU Octave License: GNU General Public License
Operating System: Linux 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6
17:47:47 UTC 2017 x86_64
----------------------------------------------------------------------
no packages installed.
octave:4> ls
dicom-0.1.1.tar.gz
octave:5> pkg install dicom-0.1.1.tar.gz
dicomlookup.cpp:23:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
directory
compilation terminated.
dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
directory
compilation terminated.
dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
directory
compilation terminated.
dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No such
file or directory

So, I need gdcm. I search in the ubuntu repositories:

~$ sudo apt-cache search gdcm
libgdcm2.6 - Grassroots DICOM runtime libraries
libvtkgdcm-java - Grassroots DICOM VTK Java bindings
libvtkgdcm-tools - Utilidades y herramientas Grassroots DICOM VTK
gdcm-doc - Grassroots DICOM documentation
libgdcm-cil - Grassroots DICOM CLI bindings
libgdcm-java - Grassroots DICOM Java bindings
libgdcm-tools - Grassroots DICOM tools and utilities
libgdcm2-dev - Grassroots DICOM development libraries and headers
libgdcm2.6-dbg - Grassroots DICOM runtime libraries, debug version
libvtkgdcm-cil - Grassroots DICOM VTK CLI bindings
libvtkgdcm2-dev - Grassroots DICOM VTK development libraries and headers
libvtkgdcm2.6 - Grassroots DICOM VTK runtime libraries
python-gdcm - Grassroots DICOM Python bindings
python-vtkgdcm - Grassroots DICOM VTK/Python bindings


I install libgdcm2.6 and libgdcm2-dev:

~$ sudo apt install libgdcm2.6 libgdcm2-dev

I try again in Octave, same errors:

octave:5> pkg install dicom-0.1.1.tar.gz
dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
directory
compilation terminated.
dicomlookup.cpp:23:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
directory
compilation terminated.
dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No such
file or directory
compilation terminated.
dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
directory


I try to locate gdcmDict.h and yes, it is in my system

~$ sudo updatedb
~$ locate gdcmDict.h
/usr/include/gdcm-2.6/gdcmDict.h

So, gdcmDict.h is there, but not under gdcm-2.0 but gdcm-2.6

Regards,
Pablo




_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Can't install dicom package (0.1.1 and 0.1.2 (user version)) in octave 4.0.2 and ubuntu 14.0

Carnë Draug
In reply to this post by Mario Briseño
On 28 January 2017 at 11:02:37 +0100, Pablo Fern?ndez Bustamante
<[hidden email]> wrote:

>
>
>
> El 28/01/17 a las 07:47, Andy Buckle escribi?:
>>
>>
>> On 27 Jan 2017 11:27 p.m., "Mario Brise?o" <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>>
>>     I've been trying a lot of things, even changing from w10 to ubuntu
>>     asa virtual
>>     machine. So, I'm not a Linux user.
>>     NO problem installing octave, but when I try to install dicom at
>>     octave CLI i
>>     have this errors:
>>
>>     pkg install dicom-0.1.1.tar.gz
>>     dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
>>     directory
>>     compilation terminated.
>>     make: *** [dicominfo.o] Error 1
>>     make: *** Waiting for unfinished jobs....
>>     dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
>>     directory
>>     compilation terminated.
>>     make: *** [dicomdict.o] Error 1
>>     dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No
>>     such file or
>>     directory
>>     compilation terminated.
>>     make: *** [dicomread.oct] Error 1
>>     make: Entering directory '/tmp/oct-gASVrN/dicom/src'
>>     mkoctfile -c  -g dicominfo.cpp
>>     mkoctfile -c  -g dicomdict.cpp
>>     mkoctfile  -L/usr/local/lib -lgdcmcharls  -lgdcmjpeg8 -lgdcmjpeg12
>>     -lgdcmjpeg16 -lgdcmCommon -lgdcmDICT -lgdcmDSED -lgdcmIOD
>>     -lgdcmMSFF   -g
>>     dicomread.cpp
>>     Makefile:51: recipe for target 'dicominfo.o' failed
>>     Makefile:57: recipe for target 'dicomdict.o' failed
>>     Makefile:44: recipe for target 'dicomread.oct' failed
>>     make: Leaving directory '/tmp/oct-gASVrN/dicom/src'
>>
>>     pkg: error running `make' for the dicom package.
>>     error: called from 'configure_make' in file
>>     /usr/share/octave/4.0.2/m/pkg/private/configure_make.m near line 96,
>>     column 9
>>
>>     I've installed the latest versions of cmake, installed the gdcm 2.6
>>     package
>>     and followed this page:
>>     http://gdcm.sourceforge.net/wiki/index.php/Compilation
>>     <http://gdcm.sourceforge.net/wiki/index.php/Compilation>
>>
>>     As I've said, I have just 5 hours using Ubuntu for the first time.
>>
>>     I'd appreciate your help!
>>
>>     _______________________________________________
>>     Help-octave mailing list
>>     [hidden email] <mailto:[hidden email]>
>>     https://lists.gnu.org/mailman/listinfo/help-octave
>>     <https://lists.gnu.org/mailman/listinfo/help-octave>
>>
>>
>>
>> Find you install the dependency, gdcm?
>>
>>
>> _______________________________________________
>> Help-octave mailing list
>> [hidden email]
>> https://lists.gnu.org/mailman/listinfo/help-octave
>
>
> I am not a dicom user but I am trying to help to diagnose the problem.
> I have recently installed ubuntu 16.04 and I have just installed octave
> from the ubuntu repositories:
>
> octave:3> ver
> ----------------------------------------------------------------------
> GNU Octave Version: 4.0.0
> GNU Octave License: GNU General Public License
> Operating System: Linux 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6
> 17:47:47 UTC 2017 x86_64
> ----------------------------------------------------------------------
> no packages installed.
> octave:4> ls
> dicom-0.1.1.tar.gz
> octave:5> pkg install dicom-0.1.1.tar.gz
> dicomlookup.cpp:23:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
> directory
> compilation terminated.
> dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
> directory
> compilation terminated.
> dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
> directory
> compilation terminated.
> dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No such
> file or directory
>
> So, I need gdcm. I search in the ubuntu repositories:
>
> ~$ sudo apt-cache search gdcm
> libgdcm2.6 - Grassroots DICOM runtime libraries
> libvtkgdcm-java - Grassroots DICOM VTK Java bindings
> libvtkgdcm-tools - Utilidades y herramientas Grassroots DICOM VTK
> gdcm-doc - Grassroots DICOM documentation
> libgdcm-cil - Grassroots DICOM CLI bindings
> libgdcm-java - Grassroots DICOM Java bindings
> libgdcm-tools - Grassroots DICOM tools and utilities
> libgdcm2-dev - Grassroots DICOM development libraries and headers
> libgdcm2.6-dbg - Grassroots DICOM runtime libraries, debug version
> libvtkgdcm-cil - Grassroots DICOM VTK CLI bindings
> libvtkgdcm2-dev - Grassroots DICOM VTK development libraries and headers
> libvtkgdcm2.6 - Grassroots DICOM VTK runtime libraries
> python-gdcm - Grassroots DICOM Python bindings
> python-vtkgdcm - Grassroots DICOM VTK/Python bindings
>
>
> I install libgdcm2.6 and libgdcm2-dev:
>
> ~$ sudo apt install libgdcm2.6 libgdcm2-dev
>
> I try again in Octave, same errors:
>
> octave:5> pkg install dicom-0.1.1.tar.gz
> dicominfo.cpp:45:33: fatal error: gdcm-2.0/gdcmReader.h: No such file or
> directory
> compilation terminated.
> dicomlookup.cpp:23:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
> directory
> compilation terminated.
> dicomread.cpp:27:38: fatal error: gdcm-2.0/gdcmImageReader.h: No such
> file or directory
> compilation terminated.
> dicomdict.cpp:30:31: fatal error: gdcm-2.0/gdcmDict.h: No such file or
> directory
>
>
> I try to locate gdcmDict.h and yes, it is in my system
>
> ~$ sudo updatedb
> ~$ locate gdcmDict.h
> /usr/include/gdcm-2.6/gdcmDict.h
>
> So, gdcmDict.h is there, but not under gdcm-2.0 but gdcm-2.6
>

The problem is that the last released version of the dicom package has
a hardcoded dependency on gdcm version 2.0 in specific places. This
has caused Octave bugs #44430 [1], #44624 [2], and #49896 [3] but they
have already been fixed in the dicom repository.

But the fixes also made the package a bit more complicated (uses
autoconf and CMake) and it currently has no maintainer and so there
has not been a release with the fix.  You can do it yourself with:

    hg clone http://hg.code.sf.net/p/octave/dicom
    cd dicom
    make install

However, even with the fix it may error.  There are certain CMake
versions where it will still fail (CMake bug #15250 [4]).  This
impacts users in Debian Jessie (current Debian stable) (Debian bug
#768877 [5]).  You may be affected by this bug in CMake if you have
libgdcm2-dev installed and the following still happens:

    $ cmake --find-package -DNAME=GDCM -DLANGUAGE=CXX
-DCOMPILER_ID=GNU -DMODE=COMPILE
    GDCM not found.
    CMake Error: Problem processing arguments. Aborting.

Carnë

[1] https://savannah.gnu.org/bugs/?44430
[2] https://savannah.gnu.org/bugs/?44624
[3] https://savannah.gnu.org/bugs/?49896
[4] https://cmake.org/Bug/view.php?id=15250
[5] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=768877

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave