Cannot install statistics pkg from the command line

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot install statistics pkg from the command line

Nick Gayeski
I have just downloaded and install GNU Octave on my Windows 7 desktop computer. I then tried to install the statistics package using the command on the next line below, and received the error message on the following lines:

 pkg install -forge package_statistics
error: get_forge_pkg: package not found: "package_statistics".  Maybe you meant "instrument-control?"
error: called from
    get_forge_pkg at line 84 column 5
    get_forge_download at line 26 column 14
    pkg at line 407 column 31

I also downloaded the statistics package 1.4.1 tar, unzipped with WinZip and installed in the the same directory in which  Octave is installed. But any command to a statistics script returns the error message that the stats pkg is not installed.

What do I need to do to install this package?

Nick


Reply | Threaded
Open this post in threaded view
|

Re: Cannot install statistics pkg from the command line

BGreen


On Wed, Nov 27, 2019 at 4:15 PM Nick Gayeski <[hidden email]> wrote:
I have just downloaded and install GNU Octave on my Windows 7 desktop computer. I then tried to install the statistics package using the command on the next line below, and received the error message on the following lines:

 pkg install -forge package_statistics
error: get_forge_pkg: package not found: "package_statistics".  Maybe you meant "instrument-control?"
error: called from
    get_forge_pkg at line 84 column 5
    get_forge_download at line 26 column 14
    pkg at line 407 column 31

I also downloaded the statistics package 1.4.1 tar, unzipped with WinZip and installed in the the same directory in which  Octave is installed. But any command to a statistics script returns the error message that the stats pkg is not installed.

What do I need to do to install this package?

Nick


If you just downloaded the most recent version, you may not need to - 5.1.0 comes with many packages pre-installed, including statistics. I just checked ("pkg list") and statistics is already installed. If that's the case for you too, then you thould be good to go as soon as you've loaded it ("pkg load statistics").


Reply | Threaded
Open this post in threaded view
|

Re: Cannot install statistics pkg from the command line

Doug Stewart-4
In reply to this post by Nick Gayeski


On Wed, Nov 27, 2019 at 4:15 PM Nick Gayeski <[hidden email]> wrote:
I have just downloaded and install GNU Octave on my Windows 7 desktop computer. I then tried to install the statistics package using the command on the next line below, and received the error message on the following lines:

 pkg install -forge package_statistics
error: get_forge_pkg: package not found: "package_statistics".  Maybe you meant "instrument-control?"
error: called from
    get_forge_pkg at line 84 column 5
    get_forge_download at line 26 column 14
    pkg at line 407 column 31

I also downloaded the statistics package 1.4.1 tar, unzipped with WinZip and installed in the the same directory in which  Octave is installed. But any command to a statistics script returns the error message that the stats pkg is not installed.

What do I need to do to install this package?

Nick

What does 
pkg list
tell you about the installed packages?

--
DASCertificate for 206392



Reply | Threaded
Open this post in threaded view
|

RE: Cannot install statistics pkg from the command line

Windhorn, Allen E [ACIM/LSA/MKT]
In reply to this post by Nick Gayeski
Nick,

From: Help-octave <help-octave-bounces+allen.windhorn=[hidden email]> On Behalf Of Nick Gayeski

> I have just downloaded and install GNU Octave on my Windows 7 desktop
> computer. I then tried to install the statistics package using the command
> on the next line below, and received the error message on the following lines:
>
> pkg install -forge package_statistics ...

The statistics package is not called package_statistics in the Octave-Forge
repository, it is just called statistics.  Try that with the -forge option.

> I also downloaded the statistics package 1.4.1 tar, unzipped with WinZip and
> installed in the the same directory in which  Octave is installed. But any
> command to a statistics script returns the error message that the stats pkg is
> not installed.

If you didn't do "pkg install" something, you didn't install the package.

Type help pkg and read the result.  And remember, you also have to load the
package before you can use it, unless you set it up to load automatically (see
previous sentence).

Regards,
Allen

Reply | Threaded
Open this post in threaded view
|

Re: Cannot install statistics pkg from the command line

Nick Gayeski
Thanks all for the prompt reply. I followed Allen's direction and used the following command to try to install the stats package, and received the included error message.
I have a current version of Windows 7 Professional and just installed the current version of GNU Octave. So I am puzzled by the error message regarding dependencies.


>> pkg install -forge statistics
error: the following dependencies were unsatisfied:
   statistics needs io >= 1.0.18

Regarding the comment that the statics pkg is not included in GNU octave I just ran the following command and received the associated error message:

>> [m,v] = normstat (2, 0.4)
warning: the 'normstat' function belongs to the statistics package from Octave
Forge which seems to not be installed in your system.

I need more help.

Cheers,

Nick

On Wed, Nov 27, 2019 at 1:46 PM Windhorn, Allen E [ACIM/LSA/MKT] <[hidden email]> wrote:
Nick,

From: Help-octave <help-octave-bounces+allen.windhorn=[hidden email]> On Behalf Of Nick Gayeski

> I have just downloaded and install GNU Octave on my Windows 7 desktop
> computer. I then tried to install the statistics package using the command
> on the next line below, and received the error message on the following lines:
>
> pkg install -forge package_statistics ...

The statistics package is not called package_statistics in the Octave-Forge
repository, it is just called statistics.  Try that with the -forge option.

> I also downloaded the statistics package 1.4.1 tar, unzipped with WinZip and
> installed in the the same directory in which  Octave is installed. But any
> command to a statistics script returns the error message that the stats pkg is
> not installed.

If you didn't do "pkg install" something, you didn't install the package.

Type help pkg and read the result.  And remember, you also have to load the
package before you can use it, unless you set it up to load automatically (see
previous sentence).

Regards,
Allen


Reply | Threaded
Open this post in threaded view
|

RE: Cannot install statistics pkg from the command line

Windhorn, Allen E [ACIM/LSA/MKT]
Nick,

From: Nick Gayeski <[hidden email]>

> Thanks all for the prompt reply. I followed Allen's direction and used the
> following command to try to install the stats package, and received the
> included error message.

>> pkg install -forge statistics
> error: the following dependencies were unsatisfied:
>  statistics needs io >= 1.0.18

Just what it says -- statistics needs the io package so install that first.

Type help pkg and read the result.  And remember, you also have to load the
package before you can use it, unless you set it up to load automatically (see
previous sentence).

Regards,
Allen