Fwd: Octave 4.0.0 release candidate 1 available for ftp

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: Octave 4.0.0 release candidate 1 available for ftp

José Luis García Pallero
Yes, I've installed the NVIDIA driver in Debian. The OpenGL drawing
doesn't work with the NVIDIA GL libraries, but this can be
workarounded installing the Debian libgl packages and changing the
links to libGL et al. in /usr/lib/x86_64-linux-gnu/ from the NVIDIA
libGL and libGLES to the Debian ones. I use this script to do it:

#!/bin/bash

#Después de instalar el driver de NVIDIA hay que reinstalar los paquetes
#libgl1-mesa-swx11, libgles1-mesa y libgles2-mesa
#Por último, hay que ejecutar este script para que los enlaces simbólicos
#apunten a las bibliotecas de los paquetes de Debian, no a las de NVIDIA

#Nos ponemos en el directorio de trabajo
cd /usr/lib/x86_64-linux-gnu
#Borramos los enlaces simbólicos no válidos
rm libGL.so libGL.so.1
rm libGLESv1_CM.so libGLESv1_CM.so.1
rm libGLESv2.so libGLESv2.so.2
#Creamos los enlaces a GL
ln -s libGL.so.1.6.0 libGL.so.1
ln -s libGL.so.1 libGL.so
#Creamos los enlaces a GLES1
ln -s libGLESv1_CM.so.1.1.0 libGLESv1_CM.so.1
ln -s libGLESv1_CM.so.1 libGLESv1_CM.so
#Creamos los enlaces a GLES2
ln -s libGLESv2.so.2.0.0 libGLESv2.so.2
ln -s libGLESv2.so.2 libGLESv2.so

--
*****************************************
José Luis García Pallero
[hidden email]
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************


--
*****************************************
José Luis García Pallero
[hidden email]
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************

Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Octave 4.0.0 release candidate 1 available for ftp

Mike Miller-4
On Tue, Mar 10, 2015 at 11:44:45 +0100, José Luis García Pallero wrote:
> Yes, I've installed the NVIDIA driver in Debian. The OpenGL drawing
> doesn't work with the NVIDIA GL libraries, but this can be
> workarounded installing the Debian libgl packages and changing the
> links to libGL et al. in /usr/lib/x86_64-linux-gnu/ from the NVIDIA
> libGL and libGLES to the Debian ones. I use this script to do it:

Please add a comment to bug #44478 [1] and help us figure out if this
bug can be fixed or not. We now have 3 users confirming the same
segfault when using Nvidia. But you are not using Nvidia's libraries, if
I understood correctly, and it still segfaults, this is interesting.

[1] https://savannah.gnu.org/bugs/?44478

--
mike