Having problem installing Econometrics and Financial packages

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Having problem installing Econometrics and Financial packages

asudipta
Can someone help with installing Econometrics and Financial packages for the latest version of Octave, i am using Ubuntu ? octave:1> pkg install -forge econometrics error: the following dependencies were unsatisfied: econometrics needs optim >= 0.0.0 octave:1> pkg install -forge finance error: get_forge_pkg: package not found: "finance". Maybe you meant "financial?" error: called from: error: /usr/share/octave/3.8.1/m/pkg/private/get_forge_pkg.m at line 73, column 9 error: /usr/share/octave/3.8.1/m/pkg/private/get_forge_download.m at line 26, column 12 error: /usr/share/octave/3.8.1/m/pkg/pkg.m at line 385, column 29 octave:1> pkg install -forge financial error: the following dependencies were unsatisfied: financial needs io >= 1.0.18 octave:1>
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

siko1056
Keep the following order to meet all dependencies.

pkg install -forge struct
pkg install -forge optim
pkg install -forge econometrics
pkg install -forge io
pkg install -forge financial

After installing don't forget to load the packages before using their functions:

pkg load econometrics

for the "econometrics" package for example.

HTH, Kai
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

asudipta
Thanks Kai,
Got the following error

octave:1> pkg install -forge struct
pkg: please install the Debian package "liboctave-dev" to get the mkoctfile command
error: called from '__gripe_missing_component__' in file /usr/share/octave/3.8.1/m/help/__gripe_missing_component__.m near line 53, column 3
error: called from:
error:   /usr/share/octave/3.8.1/m/pkg/private/install.m at line 206, column 5
error:   /usr/share/octave/3.8.1/m/pkg/pkg.m at line 394, column 9
octave:1> pkg install liboctave-dev
warning: file liboctave-dev does not exist
octave:2> quit

asudipta@asudipta-Inspiron-1525:~$ ^C
asudipta@asudipta-Inspiron-1525:~$ sudo apt-get install ^C
asudipta@asudipta-Inspiron-1525:~$ ^C
asudipta@asudipta-Inspiron-1525:~$ sudo apt-get install liboocatve-dev
[sudo] password for asudipta:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package liboocatve-dev
asudipta@asudipta-Inspiron-1525:~$


On Tue, Jan 13, 2015 at 12:36 PM, siko1056 [via Octave] <[hidden email]> wrote:
Keep the following order to meet all dependencies.

pkg install -forge struct
pkg install -forge optim
pkg install -forge econometrics
pkg install -forge io
pkg install -forge financial

After installing don't forget to load the packages before using their functions:

pkg load econometrics

for the "econometrics" package for example.

HTH, Kai


If you reply to this email, your message will be added to the discussion below:
http://octave.1599824.n4.nabble.com/Having-problem-installing-Econometrics-and-Financial-packages-tp4668103p4668105.html
To unsubscribe from Having problem installing Econometrics and Financial packages, click here.
NAML



--
Sudipta Banerjee
Consultant, Business Analytics and Cloud Based Architecture 
Call me +919019578099
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

marco atzeri-2


On 1/13/2015 8:19 AM, asudipta wrote:
> Thanks Kai,
> Got the following error
>
> octave:1> pkg install -forge struct
> pkg: please install the Debian package "liboctave-dev" to get the mkoctfile


> command
> error: called from '__gripe_missing_component__' in file
> /usr/share/octave/3.8.1/m/help/__gripe_missing_component__.m near line 53,
> column 3
> error: called from:
> error:   /usr/share/octave/3.8.1/m/pkg/private/install.m at line 206,
> column 5
> error:   /usr/share/octave/3.8.1/m/pkg/pkg.m at line 394, column 9
> octave:1> pkg install liboctave-dev
> warning: file liboctave-dev does not exist
> octave:2> quit
>
> asudipta@asudipta-Inspiron-1525:~$ ^C
> asudipta@asudipta-Inspiron-1525:~$ sudo apt-get install ^C
> asudipta@asudipta-Inspiron-1525:~$ ^C
> asudipta@asudipta-Inspiron-1525:~$ sudo apt-get install liboocatve-dev

your typo error


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

Andreas Weber-4
In reply to this post by asudipta
Am 13.01.2015 um 08:19 schrieb asudipta:

> octave:1> pkg install -forge struct
> pkg: please install the Debian package "liboctave-dev" to get the mkoctfile
> command
> ...
> asudipta@asudipta-Inspiron-1525:~$ sudo apt-get install liboocatve-dev

Please compare the suggested package and your command above.
Andy

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

asudipta
Sure, Thank you Kai for the help. It worked fine.

However when I start Octave now I get the following warning message multiple time. Can anyone suggest a solution?

warning: autoload: '__control_slicot_functions__.oct' is not an absolute file name


On Tue, Jan 13, 2015 at 1:23 PM, Andreas Weber-4 [via Octave] <[hidden email]> wrote:
Am 13.01.2015 um 08:19 schrieb asudipta:

> octave:1> pkg install -forge struct
> pkg: please install the Debian package "liboctave-dev" to get the mkoctfile
> command
> ...
> asudipta@asudipta-Inspiron-1525:~$ sudo apt-get install liboocatve-dev

Please compare the suggested package and your command above.
Andy

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave



If you reply to this email, your message will be added to the discussion below:
http://octave.1599824.n4.nabble.com/Having-problem-installing-Econometrics-and-Financial-packages-tp4668103p4668108.html
To unsubscribe from Having problem installing Econometrics and Financial packages, click here.
NAML



--
Sudipta Banerjee
Consultant, Business Analytics and Cloud Based Architecture 
Call me +919019578099
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

asudipta
In reply to this post by Andreas Weber-4
Hi , I am using this for the first time. Can some one share some examples of using the econometrics package in octave?

Thanks and regards,
Sudipta

On Tue, Jan 13, 2015 at 1:53 PM, Sudipta Banerjee <[hidden email]> wrote:
Sure, Thank you Kai for the help. It worked fine.

However when I start Octave now I get the following warning message multiple time. Can anyone suggest a solution?

warning: autoload: '__control_slicot_functions__.oct' is not an absolute file name


On Tue, Jan 13, 2015 at 1:23 PM, Andreas Weber-4 [via Octave] <[hidden email]> wrote:
Am 13.01.2015 um 08:19 schrieb asudipta:

> octave:1> pkg install -forge struct
> pkg: please install the Debian package "liboctave-dev" to get the mkoctfile
> command
> ...
> asudipta@asudipta-Inspiron-1525:~$ sudo apt-get install liboocatve-dev

Please compare the suggested package and your command above.
Andy

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave



If you reply to this email, your message will be added to the discussion below:
http://octave.1599824.n4.nabble.com/Having-problem-installing-Econometrics-and-Financial-packages-tp4668103p4668108.html
To unsubscribe from Having problem installing Econometrics and Financial packages, click here.
NAML



--
Sudipta Banerjee
Consultant, Business Analytics and Cloud Based Architecture 
Call me +919019578099



--
Sudipta Banerjee
Consultant, Business Analytics and Cloud Based Architecture 
Call me +919019578099
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

Michael Creel
The econometrics package provides routines for estimation by ML and GMM, among other things. Examples of use are in the files mle_example.m, gmm_example.m, etc. (look for *_example.m files), which are included in the package. You can see additional examples embedded in my teaching notes, at http://pareto.uab.es/mcreel/Econometrics/
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

asudipta
Thank you for sharing this. I will let you know in case of any doubts.

On Thu, Jan 15, 2015 at 5:30 PM, Michael Creel [via Octave] <[hidden email]> wrote:
The econometrics package provides routines for estimation by ML and GMM, among other things. Examples of use are in the files mle_example.m, gmm_example.m, etc. (look for *_example.m files), which are included in the package. You can see additional examples embedded in my teaching notes, at http://pareto.uab.es/mcreel/Econometrics/


If you reply to this email, your message will be added to the discussion below:
http://octave.1599824.n4.nabble.com/Having-problem-installing-Econometrics-and-Financial-packages-tp4668103p4668139.html
To unsubscribe from Having problem installing Econometrics and Financial packages, click here.
NAML



--
Sudipta Banerjee
Consultant, Business Analytics and Cloud Based Architecture 
Call me +919019578099
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

herrin53
This post has NOT been accepted by the mailing list yet.
In reply to this post by asudipta
Well dear, I can’t help you in these Econometrics and financial packages but my uncle Aloke Ghosh can help you. He runs his blog where provide free consultation regarding accounts and finance related issues. You should contact him through his blog!
Reply | Threaded
Open this post in threaded view
|

Re: Having problem installing Econometrics and Financial packages

asudipta
Tahks Herrin , I will let you incase I need any help.

BR,
Sudipta

On Fri, Feb 27, 2015 at 11:23 AM, herrin53 [via Octave] <[hidden email]> wrote:
Well dear, I can’t help you in these Econometrics and financial packages but my uncle Aloke Ghosh can help you. He runs his blog where provide free consultation regarding accounts and finance related issues. You should contact him through his blog!



If you reply to this email, your message will be added to the discussion below:
http://octave.1599824.n4.nabble.com/Having-problem-installing-Econometrics-and-Financial-packages-tp4668103p4668866.html
To unsubscribe from Having problem installing Econometrics and Financial packages, click here.
NAML



--
Sudipta Banerjee
Consultant, Business Analytics and Cloud Based Architecture 
Call me +919019578099