I don't know how to solve this problem

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

I don't know how to solve this problem

张硕
I have been learning how to use Octave. And today I wanted to use the function 'syms', but it told me I have to install package symbolic. So I downloaded it.
But it shows 'Symbolic pkg v2.7.1: 'python' is not recognized as an internal or external command, operable program or batch file.' 
error: Cannot run the Python executable "python"
I have installed 'Python 3.0', but I don't know how to solve it.
Can anyone help me?
thanks


 



Reply | Threaded
Open this post in threaded view
|

Re: I don't know how to solve this problem

Doug Stewart-4


On Fri, Apr 12, 2019 at 10:43 AM Jack <[hidden email]> wrote:
I have been learning how to use Octave. And today I wanted to use the function 'syms', but it told me I have to install package symbolic. So I downloaded it.
But it shows 'Symbolic pkg v2.7.1: 'python' is not recognized as an internal or external command, operable program or batch file.' 
error: Cannot run the Python executable "python"
I have installed 'Python 3.0', but I don't know how to solve it.
Can anyone help me?
thanks


 



I have these 2 lines  in .octaverc

setenv PYTHON python3
    sympref reset
try that and let us know how it works.

--
DASCertificate for 206392



Reply | Threaded
Open this post in threaded view
|

Re:Re: I don't know how to solve this problem

张硕
Sorry to bother again.
It shows 'You have installed but not not loaded' when I run Octave again. And after I loaded it and executed the instruction above, it still showed the same sentences.
Many thanks for your help.

在 2019-04-12 23:11:05,"Doug Stewart" <[hidden email]> 写道:


On Fri, Apr 12, 2019 at 10:43 AM Jack <[hidden email]> wrote:
I have been learning how to use Octave. And today I wanted to use the function 'syms', but it told me I have to install package symbolic. So I downloaded it.
But it shows 'Symbolic pkg v2.7.1: 'python' is not recognized as an internal or external command, operable program or batch file.' 
error: Cannot run the Python executable "python"
I have installed 'Python 3.0', but I don't know how to solve it.
Can anyone help me?
thanks


 



I have these 2 lines  in .octaverc

setenv PYTHON python3
    sympref reset
try that and let us know how it works.

--
DASCertificate for 206392



 



Reply | Threaded
Open this post in threaded view
|

Re: I don't know how to solve this problem

Colin Macdonald-2
On 2019-04-13 11:20 a.m., 张硕 wrote:
> Sorry to bother again.
> It shows 'You have installed but not not loaded' when I run Octave
> again. And after I loaded it and executed the instruction above, it
> still showed the same sentences.
> Many thanks for your help.

Are you on Windows OS?

Have you read this?

https://github.com/cbm755/octsympy/wiki/Notes-on-Windows-installation

Colin


Reply | Threaded
Open this post in threaded view
|

Re:Re: I don't know how to solve this problem

张硕
My problem has been solved.<br/>Thank you for your answer!
At 2019-04-13 12:58:18, "Colin Macdonald" <[hidden email]> wrote:

>On 2019-04-13 11:20 a.m., 张硕 wrote:
>> Sorry to bother again.
>> It shows 'You have installed but not not loaded' when I run Octave
>> again. And after I loaded it and executed the instruction above, it
>> still showed the same sentences.
>> Many thanks for your help.
>
>Are you on Windows OS?
>
>Have you read this?
>
>https://github.com/cbm755/octsympy/wiki/Notes-on-Windows-installation
>
>Colin