Installation of miscellaneous-1.0.11 package

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Installation of miscellaneous-1.0.11 package

Yoshi Yamada
Hi everyone,

Sorry for asking a basic question, but I was trying to install miscellaneous-1.0.11 package and it wouldn't work, with an error message as below:

configure: error: in `/var/tmp/oct-FH3tCL/miscellaneous-1.0.11/src':
configure: error: C compiler cannot create executables
See `config.log' for more details
the configure script returned the following error: checking for gcc... /usr/bin/gcc-4.2
checking whether the C compiler works... no
error: called from `pkg>configure_make' in file /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m near line 1320, column 9
error: called from:
error:   /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 783, column 5
error:   /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 354, column 9

My working environment is:
Mac OS X 10.6.7 (X-code already installed)
Octave-3.4.0

Could you tell me how to fix this (and where I can find 'config.log' file)?  
Thank you in advance for your kind help!

Best wishes,
Yoshi
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Sergei Steshenko


--- On Tue, 4/5/11, Yoshi Yamada <[hidden email]> wrote:

> From: Yoshi Yamada <[hidden email]>
> Subject: Installation of miscellaneous-1.0.11 package
> To: [hidden email]
> Date: Tuesday, April 5, 2011, 11:43 PM
> Hi everyone,
>
> Sorry for asking a basic question, but I was trying to
> install
> miscellaneous-1.0.11 package and it wouldn't work, with an
> error message as
> below:
>
> configure: error: in
> `/var/tmp/oct-FH3tCL/miscellaneous-1.0.11/src':
> configure: error: C compiler cannot create executables
> See `config.log' for more details
> the configure script returned the following error: checking
> for gcc...
> /usr/bin/gcc-4.2
> checking whether the C compiler works... no
> error: called from `pkg>configure_make' in file
> /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m
> near line 1320, column 9
> error: called from:
> error: 
> /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m
> at line 783, column 5
> error: 
> /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m
> at line 354, column 9
>
> My working environment is:
> Mac OS X 10.6.7 (X-code already installed)
> Octave-3.4.0
>
> Could you tell me how to fix this (and where I can find
> 'config.log' file)? 
> Thank you in advance for your kind help!
>
> Best wishes,
> Yoshi
>
> --
> View this message in context: http://octave.1599824.n4.nabble.com/Installation-of-miscellaneous-1-0-11-package-tp3430036p3430036.html
> Sent from the Octave - General mailing list archive at
> Nabble.com.
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://mailman.cae.wisc.edu/listinfo/help-octave
>

The "C compiler cannot create executables" message is not quite precise.

What it actually means is that your "C" compiler with the setting provided
by you and 'configure' cannot create executables. E.g. if for whatever
reason '-lfoo' is given, and no libfoo.* can be found by linker, the
linking part will fail and you'll get the message you've got.

You really need to have a look into 'config.log' - in such cases you can
find the full command line and the failed test program which caused the
failure.

There is no common/generic answer for this error message.

Regards,
  Sergei.
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Yoshi Yamada
Thanks a lot. Embarrassing to ask, but how can I get to the config.log file?

Best,
Yoshi
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Sergei Steshenko


--- On Wed, 4/6/11, Yoshi Yamada <[hidden email]> wrote:

> From: Yoshi Yamada <[hidden email]>
> Subject: Re: Installation of miscellaneous-1.0.11 package
> To: [hidden email]
> Date: Wednesday, April 6, 2011, 7:22 AM
> Thanks a lot. Embarrassing to ask,
> but how can I get to the config.log file?
>
> Best,
> Yoshi
>
> --
> View this message in context: http://octave.1599824.n4.nabble.com/Installation-of-miscellaneous-1-0-11-package-tp3430036p3430886.html
> Sent from the Octave - General mailing list archive at
> Nabble.com.
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://mailman.cae.wisc.edu/listinfo/help-octave
>

It is created by 'configure' automatically and is typically located in the same directory in which 'configure' is run.

By the way, another popular cause of the trouble is a missing library, e.g.
'libfoo' which is present needs 'libbar' which is missing.

Regards,
  Sergei.
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Yoshi Yamada
Thank you very much for your reply again.
I tried to install the package by typing
'pkg install miscellaneous-1.0.11'
in the x-term command line and could not find any files named 'config.log'.
Am I searching it in a wrong way?
Or should I try another way of installation?

Best,
Yoshi


--
View this message in context: http://octave.1599824.n4.nabble.com/Installation-of-miscellaneous-1-0-11-package-tp3430036p3432467.html
Sent from the Octave - General mailing list archive at Nabble.com.
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Sergei Steshenko


--- On Wed, 4/6/11, Yoshi Yamada <[hidden email]> wrote:

> From: Yoshi Yamada <[hidden email]>
> Subject: Re: Installation of miscellaneous-1.0.11 package
> To: [hidden email]
> Date: Wednesday, April 6, 2011, 9:39 PM
> Thank you very much for your reply
> again.
> I tried to install the package by typing
> 'pkg install miscellaneous-1.0.11'
> in the x-term command line and could not find any files
> named 'config.log'.
> Am I searching it in a wrong way?
> Or should I try another way of installation?
>
> Best,
> Yoshi
>
>
> --
> View this message in context: http://octave.1599824.n4.nabble.com/Installation-of-miscellaneous-1-0-11-package-tp3430036p3432467.html
> Sent from the Octave - General mailing list archive at
> Nabble.com.
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://mailman.cae.wisc.edu/listinfo/help-octave
>

In may case:

build/octave-forge-bundle-20080831/main/miscellaneous-1.0.7/src/config.log
.

I.e. under 'build' I had octave-forge-bundle-20080831.tar.gz which
of course, was unpacked.

Probably use 'find' command command - something like

find . -name config.log

- where '.' is current directory from which you invoke 'octave'.

The above is for Linux; I hope under MacOS 'find' basically works the same.

Regards,
 Sergei.
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Yoshi Yamada
Command 'pkg build . miscellaneous-1.0.11.tar' did work on Mac but only to create an empty folder named 'install'... ?

But when I ran the same command in another machine, I got a more specific error message in the x-term:
--
ld: library not found for -lgfortranbegin
collect2: ld returned 1 exit status
configure: error: Could not run /Applications/Octave.app/Contents/Resources/bin/mkoctfile-3.4.0
the configure script returned the following error: checking for gcc... /usr/bin/gcc-4.2
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.2 accepts -g... yes
checking for /usr/bin/gcc-4.2 option to accept ISO C89... none needed
checking for mkoctfile... /Applications/Octave.app/Contents/Resources/bin/mkoctfile-3.4.0
error: called from `pkg>configure_make' in file /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m near line 1320, column 9
error: called from:
error:   /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 783, column 5
error:   /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 592, column 3
error:   /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 464, column 7
--

Could you tell me how to fix these problems?
Thank you for your continuous help and patience.

Best,
Yoshi
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

dersh
In reply to this post by Yoshi Yamada
I have run into a problem that is clearly very similar, although not line for line identical.  I just upgraded to octave 3.4.0 (mac binary release).  I then tried to upgrade some packages by installing new versions.  I am getting very similar errors to what was posted below, for a few different packages.
Any suggestions?

Here is the full error set:

pkg install /Users/dersh/Desktop/Downloads/miscellaneous-1.0.11.tar.gz
warning: file /Users/dersh/Desktop/Downloads/miscellaneous-1.0.11.tar.gz does not exist
octave-3.4.0:13> pkg install /Users/dersh/Desktop/Downloads/miscellaneous-1.0.11.tar.gz
ld: warning: directory '/tmp/deps-i386/lib' following -L not found
ld: warning: directory '/tmp/deps-i386/lib/gcc/i686-apple-darwin10/4.2.1' following -L not found
ld: warning: directory '/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1' following -L not found
ld: warning: directory '/private/tmp/deps-i386/bin/../lib/gcc' following -L not found
ld: warning: directory '/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1/../../..' following -L not found
ld: library not found for -lgfortranbegin
collect2: ld returned 1 exit status
configure: error: Could not run /Applications/Others/Octave.app/Contents/Resources/bin/mkoctfile-3.4.0
the configure script returned the following error: checking for gcc... /usr/bin/gcc-4.2
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.2 accepts -g... yes
checking for /usr/bin/gcc-4.2 option to accept ISO C89... none needed
checking for mkoctfile... /Applications/Others/Octave.app/Contents/Resources/bin/mkoctfile-3.4.0
error: called from `pkg>configure_make' in file /Applications/Others/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m near line 1325, column 9
error: called from:
error:   /Applications/Others/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 783, column 5
error:   /Applications/Others/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 354, column 9


Thanks much,
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Julien Salort
dersh <[hidden email]> writes:

> I have run into a problem that is clearly very similar, although not line for
> line identical.  I just upgraded to octave 3.4.0 (mac binary release).  I
> then tried to upgrade some packages by installing new versions.  I am
> getting very similar errors to what was posted below, for a few different
> packages.
> Any suggestions?

Hello,

I need to build a package with better mkoctfile options indeed.

In the mean time, you can do the following:
Edit /Applications/Octave.app/Contents/Resources/bin/mkoctfile
and change line 43 to
LDFLAGS="-arch i386 -L/Applications/Octave.app/Contents/Resources/lib/gcc/i686-apple-darwin10/4.2.1 -L${ROOT}/lib -L${ROOT}/lib/octave-3.4.0 ${LDFLAGS}"

I thought I had done that already in the latest build but maybe it hasn't been uploaded to sourceforge...

Hope this helps,

Julien

--
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on a mailing list?

_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

drkbts
Just installed the binary version of Octave on MaxOS X 10.6.7 and I am having the same problems. I checked the mkoctfile, but found no problems with LDFLAGS variable. Any help is appreciated.

Ton


octave-3.4.0:3> pkg install audio-1.1.4.tar.gz
ld: warning: directory not found for option '-L/tmp/deps-i386/lib'
ld: warning: directory not found for option '-L/tmp/deps-i386/lib/gcc/i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib'
ld: warning: directory not found for option '-L/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/private/tmp/deps-i386/bin/../lib/gcc'
ld: warning: directory not found for option '-L/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1/../../..'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/gcc/i686-apple-darwin10/4.2.1/../../../i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/gcc/i686-apple-darwin10/4.2.1/../../..'
ld: library not found for -lgfortranbegin
collect2: ld returned 1 exit status
configure: error: Could not run /Applications/Octave.app/Contents/Resources/bin/mkoctfile-3.4.0
the configure script returned the following error: checking for gcc... /usr/bin/gcc-4.2
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.2 accepts -g... yes
checking for /usr/bin/gcc-4.2 option to accept ISO C89... none needed
checking for mkoctfile... /Applications/Octave.app/Contents/Resources/bin/mkoctfile-3.4.0
error: called from `pkg>configure_make' in file /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m near line 1325, column 9
error: called from:
error:   /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 783, column 5
error:   /Applications/Octave.app/Contents/Resources/share/octave/3.4.0/m/pkg/pkg.m at line 354, column 9
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

drkbts
It was pointed out to me that I should install gfortran ....

I did, but I am now stuck at a missing fortran library (gfortranbegin)

Ton

octave-3.4.0:3> pkg install audio-1.1.4.tar.gz
ld: warning: directory not found for option '-L/tmp/deps-i386/lib'
ld: warning: directory not found for option '-L/tmp/deps-i386/lib/gcc/i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib'
ld: warning: directory not found for option '-L/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/private/tmp/deps-i386/bin/../lib/gcc'
ld: warning: directory not found for option '-L/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1/../../..'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/gcc/i686-apple-darwin10/4.2.1/../../../i686-apple-darwin10/4.2.1'
ld: warning: directory not found for option '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/gcc/i686-apple-darwin10/4.2.1/../../..'
ld: library not found for -lgfortranbegin
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Sergei Steshenko


--- On Fri, 5/13/11, drkbts <[hidden email]> wrote:

> From: drkbts <[hidden email]>
> Subject: Re: Installation of miscellaneous-1.0.11 package
> To: [hidden email]
> Date: Friday, May 13, 2011, 1:01 PM
> It was pointed out to me that I
> should install gfortran ....
>
> I did, but I am now stuck at a missing fortran library
> (gfortranbegin)
>
> Ton
>
> octave-3.4.0:3> pkg install audio-1.1.4.tar.gz
> ld: warning: directory not found for option
> '-L/tmp/deps-i386/lib'
> ld: warning: directory not found for option
> '-L/tmp/deps-i386/lib/gcc/i686-apple-darwin10/4.2.1'
> ld: warning: directory not found for option
> '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/i686-apple-darwin10/4.2.1'
> ld: warning: directory not found for option
> '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib'
> ld: warning: directory not found for option
> '-L/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1'
> ld: warning: directory not found for option
> '-L/private/tmp/deps-i386/bin/../lib/gcc'
> ld: warning: directory not found for option
> '-L/private/tmp/deps-i386/bin/../lib/gcc/i686-apple-darwin10/4.2.1/../../..'
> ld: warning: directory not found for option
> '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/gcc/i686-apple-darwin10/4.2.1/../../../i686-apple-darwin10/4.2.1'
> ld: warning: directory not found for option
> '-L/Developer/SDKs/MacOSX10.5.sdk/usr/lib/gcc/i686-apple-darwin10/4.2.1/../../..'
> ld: library not found for -lgfortranbegin
>
>
> --

I vaguely remember that organization of Fortran libraries evolved with
'gcc' evolution.

It may be that that Octave version was built with a different than you
have 'gcc' version. But it's a wild guess.

Regards,
  Sergei.
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installation of miscellaneous-1.0.11 package

Julien Salort
In reply to this post by drkbts
drkbts <[hidden email]> writes:

> Just installed the binary version of Octave on MaxOS X 10.6.7 and I am having
> the same problems. I checked the mkoctfile, but found no problems with
> LDFLAGS variable. Any help is appreciated.

Please try with this version:
http://www.juliensalort.org/octave/octave-3.4.0-i386-20110421.dmg

I will upload it to sourceforge as soon as I find out how.

--
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on a mailing list?

_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave