Installing Octave 3.2.3 / BLAS incompatibility on a Mac

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing Octave 3.2.3 / BLAS incompatibility on a Mac

Jeff Pickhardt
Hi,

I'm having trouble installing the latest version of Octave on a new MacBook Pro, because I get the following error in configuration:

configure: error: A BLAS library was detected but found incompatible with your Fortran 77 compiler settings.

I've read that Octave 3.2.3 would work -- anyone know where I can download this?

Thanks,
Jeff

PS - Alternatively, if there's something I can do to use the most recent version of Octave, that'd work too. :)

--
Jeff Pickhardt
(650) 530-0036
[hidden email]


_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installing Octave 3.2.3 / BLAS incompatibility on a Mac

Liam Groener-2

On Jun 11, 2011, at 10:00 AM, Jeff Pickhardt wrote:

Hi,

I'm having trouble installing the latest version of Octave on a new MacBook Pro, because I get the following error in configuration:

configure: error: A BLAS library was detected but found incompatible with your Fortran 77 compiler settings.

I've read that Octave 3.2.3 would work -- anyone know where I can download this?

Thanks,
Jeff

PS - Alternatively, if there's something I can do to use the most recent version of Octave, that'd work too. :)

--
Jeff Pickhardt
(650) 530-0036
[hidden email]

_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave

There are two easy ways:
1. Download a pre-built binary of either 3.4 (the latest) or 3.23 from:
or
2. Use Mac Ports to build either 3.24 or 3.4 (listed as octave-devel)

The Mac Ports builds have the advantage that thy are 64 bits, but the 3.4 build lacks the optional fltk graphics engine. 

_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Installing Octave 3.2.3 / BLAS incompatibility on a Mac

Jeff Pickhardt
That works, thanks!

--
Jeff Pickhardt
(650) 530-0036
[hidden email]



On Sat, Jun 11, 2011 at 11:57 AM, Liam Groener <[hidden email]> wrote:

On Jun 11, 2011, at 10:00 AM, Jeff Pickhardt wrote:

Hi,

I'm having trouble installing the latest version of Octave on a new MacBook Pro, because I get the following error in configuration:

configure: error: A BLAS library was detected but found incompatible with your Fortran 77 compiler settings.

I've read that Octave 3.2.3 would work -- anyone know where I can download this?

Thanks,
Jeff

PS - Alternatively, if there's something I can do to use the most recent version of Octave, that'd work too. :)

--
Jeff Pickhardt
<a href="tel:%28650%29%20530-0036" value="+16505300036" target="_blank">(650) 530-0036
[hidden email]

_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave

There are two easy ways:
1. Download a pre-built binary of either 3.4 (the latest) or 3.23 from:
or
2. Use Mac Ports to build either 3.24 or 3.4 (listed as octave-devel)

The Mac Ports builds have the advantage that thy are 64 bits, but the 3.4 build lacks the optional fltk graphics engine. 


_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave