Mac OS ver 4.4.1 - Cannot install any packages

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Mac OS ver 4.4.1 - Cannot install any packages

llopez04
Hey folks, tried searching for this issue but didn't come across anything
helpful.

I've just installed ver 4.4.1 in my Mac, running Mojave.  Was previously
running version 3.8 of Octave.

When I went to install a package (mapping) I got the following error:

>> pkg install -forge mapping
configure: error: in
`/var/folders/m1/6dyc8zjx10x4sgszlhg5tsfm0000gn/T/oct-NslrKR/mapping-1.2.1/src':
configure: error: C++ compiler cannot create executables
See `config.log' for more details
checking whether the C++ compiler works... no

pkg: error running the configure script for mapping.
error: called from
    configure_make at line 82 column 9
    install at line 184 column 7
    pkg at line 437 column 9

tried a different package (linear-algebra) and pretty much got the same
thing.

>> pkg install -forge linear-algebra
configure: error: in
`/var/folders/m1/6dyc8zjx10x4sgszlhg5tsfm0000gn/T/oct-B1e1PB/linear-algebra/src':
configure: error: C compiler cannot create executables
See `config.log' for more details
checking for gcc... clang
checking whether the C compiler works... no

pkg: error running the configure script for linear-algebra.
error: called from
    configure_make at line 82 column 9
    install at line 184 column 7
    pkg at line 437 column 9

Any help is greatly appreciated, I'm sure it is something with the machine,
not necessarily the Octave install.

L.



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

Andreas Weber-6
Am 29.03.19 um 20:57 schrieb llopez04:
> I've just installed ver 4.4.1 in my Mac, running Mojave.

How have you installed GNU Octave? Via fink, macports, homebrew or the
native Mac app from http://octave-app.org/ ?

-- Andy


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

llopez04
I installed it via the native Mac app from http://octave-app.org

Thanks in advance.

Sent from my iPhone

> On Mar 29, 2019, at 5:28 PM, Andreas Weber <[hidden email]> wrote:
>
>> Am 29.03.19 um 20:57 schrieb llopez04:
>> I've just installed ver 4.4.1 in my Mac, running Mojave.
>
> How have you installed GNU Octave? Via fink, macports, homebrew or the native Mac app from http://octave-app.org/ ?
>
> -- Andy



Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

llopez04
In reply to this post by llopez04
P.S. - The installation was via the native Mac app from
http://octave-app.org/



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

tmacchant
In reply to this post by llopez04
----- Original Message -----

> From: llopez04 
> To: help-octave
> Cc:
> Date: 2019/3/30, Sat 04:57
> Subject: Mac OS ver 4.4.1 - Cannot install any packages
>
> Hey folks, tried searching for this issue but didn't come across anything
> helpful.
>
> I've just installed ver 4.4.1 in my Mac, running Mojave.  Was previously
> running version 3.8 of Octave.
>
> When I went to install a package (mapping) I got the following error:
>
>>>  pkg install -forge mapping
> configure: error: in
> `/var/folders/m1/6dyc8zjx10x4sgszlhg5tsfm0000gn/T/oct-NslrKR/mapping-1.2.1/src':
> configure: error: C++ compiler cannot create executables
> See `config.log' for more details
> checking whether the C++ compiler works... no
>
> pkg: error running the configure script for mapping.
> error: called from
>     configure_make at line 82 column 9
>     install at line 184 column 7
>     pkg at line 437 column 9
>
> tried a different package (linear-algebra) and pretty much got the same
> thing.
>
>>>  pkg install -forge linear-algebra
> configure: error: in
> `/var/folders/m1/6dyc8zjx10x4sgszlhg5tsfm0000gn/T/oct-B1e1PB/linear-algebra/src':
> configure: error: C compiler cannot create executables
> See `config.log' for more details
> checking for gcc... clang
> checking whether the C compiler works... no
>
> pkg: error running the configure script for linear-algebra.
> error: called from
>     configure_make at line 82 column 9
>     install at line 184 column 7
>     pkg at line 437 column 9
>
> Any help is greatly appreciated, I'm sure it is something with the machine,
> not necessarily the Octave install.
>
> L.



I am not a mac user.
But error messages clearly states  that C and C++ compilers are not detected.

Did you install build environments in your mac?

Tatsuro 


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

apjanke-floss


On 3/29/19 7:33 PM, Tatsuro MATSUOKA wrote:

> ----- Original Message -----
>
>> From: llopez04
>> To: help-octave
>> Cc:
>> Date: 2019/3/30, Sat 04:57
>> Subject: Mac OS ver 4.4.1 - Cannot install any packages
>>
>> Hey folks, tried searching for this issue but didn't come across anything
>> helpful.
>>
>> I've just installed ver 4.4.1 in my Mac, running Mojave.  Was previously
>> running version 3.8 of Octave.
>>
>> When I went to install a package (mapping) I got the following error:
>>
>>>>   pkg install -forge mapping
>> configure: error: in
>> `/var/folders/m1/6dyc8zjx10x4sgszlhg5tsfm0000gn/T/oct-NslrKR/mapping-1.2.1/src':
>> configure: error: C++ compiler cannot create executables
>> See `config.log' for more details
>> checking whether the C++ compiler works... no.

Make sure that you have Xcode installed, and that you have actually
launched it interactively once to accept its End User License Agreement,
otherwise it will refuse to work for you.

Cheers,
Andrew


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

apjanke-floss
In reply to this post by Andreas Weber-6


On 3/29/19 5:28 PM, Andreas Weber wrote:
> Am 29.03.19 um 20:57 schrieb llopez04:
>> I've just installed ver 4.4.1 in my Mac, running Mojave.
>
> How have you installed GNU Octave? Via fink, macports, homebrew or the
> native Mac app from http://octave-app.org/ ?
>
> -- Andy

I'm an Octave.app maintainer. :) I use it, Homebrew (but with my own
formulae that include extra patches to make the GUI work right:
https://github.com/octave-app/homebrew-octave-app), and builds from source.

If you have trouble with Octave.app itself or the brew formulae we
provide there, you can drop a bug report at
https://github.com/octave-app/octave-app and I'll try to get you
straightened out.

Cheers,
Andrew


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

apjanke-floss


On 3/29/19 9:45 PM, Andrew Janke wrote:

>
>
> On 3/29/19 5:28 PM, Andreas Weber wrote:
>> Am 29.03.19 um 20:57 schrieb llopez04:
>>> I've just installed ver 4.4.1 in my Mac, running Mojave.
>>
>> How have you installed GNU Octave? Via fink, macports, homebrew or the
>> native Mac app from http://octave-app.org/ ?
>>
>> -- Andy
>
> I'm an Octave.app maintainer. :) I use it, Homebrew (but with my own
> formulae that include extra patches to make the GUI work right:
> https://github.com/octave-app/homebrew-octave-app), and builds from source.
>
> If you have trouble with Octave.app itself or the brew formulae we
> provide there, you can drop a bug report at
> https://github.com/octave-app/octave-app and I'll try to get you
> straightened out.
>
> Cheers,
> Andrew

Oh, sorry! Got you confused with the original poster; I guess that
message didn't make much sense.

Andrew


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

apjanke-floss
In reply to this post by llopez04


On 3/29/19 6:19 PM, llopez04 wrote:
> P.S. - The installation was via the native Mac app from
> http://octave-app.org/
>
That one still requires Xcode to work, since it uses Xcode to do its
builds for packages with C/C++/Fortran code. Make sure to launch Xcode
once and accept the EULA, and then it might Just Work.

Cheers,
Andrew


Reply | Threaded
Open this post in threaded view
|

Re: Mac OS ver 4.4.1 - Cannot install any packages

llopez04
Right on Andy, thanks.  Installed XCode and I’ve been able to install most of the packages I’m interested in.  Still having trouble with the communications package though, can share those errors if needed (something like fatal error octave/config.h file not found)

thanks,
L.



> On Mar 29, 2019, at 9:49 PM, Andrew Janke <[hidden email]> wrote:
>
>
>
>> On 3/29/19 6:19 PM, llopez04 wrote:
>> P.S. - The installation was via the native Mac app from
>> http://octave-app.org/
> That one still requires Xcode to work, since it uses Xcode to do its builds for packages with C/C++/Fortran code. Make sure to launch Xcode once and accept the EULA, and then it might Just Work.
>
> Cheers,
> Andrew