Minimum g++ version?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Minimum g++ version?

Rik-4
All,

The configure.ac file is checking the g++ version twice which is
unnecessary.  In one case, it issues a warning if the version <= 3.0 and in
the other it issues a warning if version <= 3.5.  Which version should we keep?

--Rik

Reply | Threaded
Open this post in threaded view
|

Re: Minimum g++ version?

Daniel Sebald
On 11/23/2014 08:28 PM, Rik wrote:
> All,
>
> The configure.ac file is checking the g++ version twice which is
> unnecessary.  In one case, it issues a warning if the version<= 3.0 and in
> the other it issues a warning if version<= 3.5.  Which version should we keep?

I'm at 4.5.1 with a system that is about three years old.  How about
3.5?  Unless there is someone with a compiler between 3.0 and 3.5 I
don't think it's worth the effort to rollback to an older version to
test if in fact < 3.5 causes compile problems.

Dan

Reply | Threaded
Open this post in threaded view
|

Re: Minimum g++ version?

Mike Miller
In reply to this post by Rik-4
On Sun, Nov 23, 2014 at 9:28 PM, Rik wrote:
> The configure.ac file is checking the g++ version twice which is
> unnecessary.  In one case, it issues a warning if the version <= 3.0 and in
> the other it issues a warning if version <= 3.5.  Which version should we keep?

I am able to compile with gcc 4.1.2 on RHEL 5, although must use
--disable-atomic-refcount.

I honestly think you would be hard-pressed to find someone trying to
use the latest Octave with a gcc older than 4. I think both version
checks and warnings should be scrapped.

--
mike

Reply | Threaded
Open this post in threaded view
|

Re: Minimum g++ version?

John W. Eaton
Administrator
In reply to this post by Rik-4
On 11/23/2014 09:28 PM, Rik wrote:
> All,
>
> The configure.ac file is checking the g++ version twice which is
> unnecessary.  In one case, it issues a warning if the version <= 3.0 and in
> the other it issues a warning if version <= 3.5.  Which version should we keep?

Those tests were added a long time ago, originally to prevent people
from going too far in attempts to compile Octave with GCC 1.x or other
versions that clearly wouldn't work.  Maybe now we could just remove the
checks completely.

If you decide to leave them in, then I think it makes sense to just warn
for versions earlier than 4.1.x.

jwe



Reply | Threaded
Open this post in threaded view
|

Re: Minimum g++ version?

John W. Eaton
Administrator
In reply to this post by Daniel Sebald
On 11/23/2014 09:39 PM, Daniel J Sebald wrote:

> I'm at 4.5.1 with a system that is about three years old.  How about
> 3.5?  Unless there is someone with a compiler between 3.0 and 3.5 I
> don't think it's worth the effort to rollback to an older version to
> test if in fact < 3.5 causes compile problems.

I haven't tried lately, but I'd be very surprised if the current Octave
sources could be compiled with any GCC 3.x version.

jwe