Multiple plots saving issues

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Multiple plots saving issues

ignas
Hi,

I have encountered a problem related to saving multiple images to separate
files. My script is basically the loop which calculates a f(x) dependency,
plots it and saves to file. After 1000 or so iterations it halts and gives
out the following:

"error: print: failed to open pipe "|/usr/bin/gs -dQUIET -dNOPAUSE -dBATCH
-dSAFER -dAutoRotatePages=/None -sDEVICE=png16m -dLanguageLevel=2
-dTextAlphaBits=4 -dGraphicsAlphaBits=1 -r72x72 -dEPSCrop
-sOutputFile="./alo/rt_alo14856.png" -"
error: called from
    __opengl_print__ at line 169 column 7
    print at line 519 column 14
    ganalo_php at line 125"

After this happens I can not save any more images to files unless I restart
Octave. I am confused and do not know were to start the debugging. Is it the
fault of Octave or Ghostscript? Any help is appreciated.

Cheers,
Ignas





--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Multiple plots saving issues

Francesco Potortì
>I have encountered a problem related to saving multiple images to separate
>files. My script is basically the loop which calculates a f(x) dependency,
>plots it and saves to file. After 1000 or so iterations it halts and gives
>out the following:
>
>"error: print: failed to open pipe "|/usr/bin/gs -dQUIET -dNOPAUSE -dBATCH
>-dSAFER -dAutoRotatePages=/None -sDEVICE=png16m -dLanguageLevel=2
>-dTextAlphaBits=4 -dGraphicsAlphaBits=1 -r72x72 -dEPSCrop
>-sOutputFile="./alo/rt_alo14856.png" -"
>error: called from
>    __opengl_print__ at line 169 column 7
>    print at line 519 column 14
>    ganalo_php at line 125"
>
>After this happens I can not save any more images to files unless I restart
>Octave.

Is there a specific reason why you are using the gnuplot toolkit?

If fltk works on your system, you should have more stable and faster
behaviour using it.  Just try this before plotting:

 graphics_toolkit("fltk")

If you are forced using gnuplot, try forcing a small delay between
plotting commands, like this:

 pause(0.2)

this may help your operating system and file system while it exchanges
data with gnuplot through a pipe.  If time is not an issue, you can try
setting a longer pause, just to be sure:

 pause(1)

--
IPIN'19 http://ipin2019.isti.cnr.it    Voice:  +39.050.621.3058
Francesco Potortì (ricercatore)        Mobile: +39.348.8283.107
ISTI - Area della ricerca CNR          Skype:  wnlabisti
via G. Moruzzi 1, I-56124 Pisa         Web:    http://fly.isti.cnr.it



Reply | Threaded
Open this post in threaded view
|

Re: Multiple plots saving issues

tmacchant
In reply to this post by ignas
-- Potorti

> >I have encountered a problem related to saving multiple images to separate
> >files. My script is basically the loop which calculates a f(x) dependency,
> >plots it and saves to file. After 1000 or so iterations it halts and gives
> >out the following:
> >
> >"error: print: failed to open pipe "|/usr/bin/gs -dQUIET -dNOPAUSE -dBATCH
> >-dSAFER -dAutoRotatePages=/None -sDEVICE=png16m -dLanguageLevel=2
> >-dTextAlphaBits=4 -dGraphicsAlphaBits=1 -r72x72 -dEPSCrop
> >-sOutputFile="./alo/rt_alo14856.png" -"
> >error: called from
> >    __opengl_print__ at line 169 column 7
> >    print at line 519 column 14
> >    ganalo_php at line 125"
> >
> >After this happens I can not save any more images to files unless I restart
> >Octave.
>
> Is there a specific reason why you are using the gnuplot toolkit?
>
> If fltk works on your system, you should have more stable and faster
> behaviour using it.  Just try this before plotting:
>
>  graphics_toolkit("fltk")
>
> If you are forced using gnuplot, try forcing a small delay between
> plotting commands, like this:
>
>  pause(0.2)
>
> this may help your operating system and file system while it exchanges
> data with gnuplot through a pipe.  If time is not an issue, you can try
> setting a longer pause, just to be sure:
>
>  pause(1)
>
> --
> IPIN'19 http://ipin2019.isti.cnr.it    Voice:  +39.050.621.3058
> Francesco Potortì (ricercatore)        Mobile: +39.348.8283.107
> ISTI - Area della ricerca CNR          Skype:  wnlabisti
> via G. Moruzzi 1, I-56124 Pisa         Web:    http://fly.isti.cnr.it
>
>

From the error message, the author did not use gnuplot graphics_tookit.


> >error: called from
> >    __opengl_print__ at line 169 column 7

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: Multiple plots saving issues

Pantxo
In reply to this post by ignas
ignas wrote

> Hi,
>
> I have encountered a problem related to saving multiple images to separate
> files. My script is basically the loop which calculates a f(x) dependency,
> plots it and saves to file. After 1000 or so iterations it halts and gives
> out the following:
>
> "error: print: failed to open pipe "|/usr/bin/gs -dQUIET -dNOPAUSE -dBATCH
> -dSAFER -dAutoRotatePages=/None -sDEVICE=png16m -dLanguageLevel=2
> -dTextAlphaBits=4 -dGraphicsAlphaBits=1 -r72x72 -dEPSCrop
> -sOutputFile="./alo/rt_alo14856.png" -"
> error: called from
>     __opengl_print__ at line 169 column 7
>     print at line 519 column 14
>     ganalo_php at line 125"
>
> After this happens I can not save any more images to files unless I
> restart
> Octave. I am confused and do not know were to start the debugging. Is it
> the
> fault of Octave or Ghostscript? Any help is appreciated.
>
> Cheers,
> Ignas
>
> --
> Sent from:
> http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html

Hi,

This could be related to this bug:

https://savannah.gnu.org/bugs/?func=detailitem&item_id=50686

The bug has been  closed in absence of response from previous posters, but
don't hesitate to test whether you can reproduce it.

I assume you are not using the latest Octave 5.1 since by default GS is no
more used to produce PNG files. Could you test the latest version of Octave?

Pantxo



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Multiple plots saving issues

ignas
Thank you all to your replies.

I was using fltk toolkit, did try qt, however the result was even worse.

Currently I am running Octave 4.2.1, will try 5.1 though.

Ignas

On Sat, Apr 13, 2019 at 11:24 PM Pantxo <[hidden email]> wrote:
ignas wrote
> Hi,
>
> I have encountered a problem related to saving multiple images to separate
> files. My script is basically the loop which calculates a f(x) dependency,
> plots it and saves to file. After 1000 or so iterations it halts and gives
> out the following:
>
> "error: print: failed to open pipe "|/usr/bin/gs -dQUIET -dNOPAUSE -dBATCH
> -dSAFER -dAutoRotatePages=/None -sDEVICE=png16m -dLanguageLevel=2
> -dTextAlphaBits=4 -dGraphicsAlphaBits=1 -r72x72 -dEPSCrop
> -sOutputFile="./alo/rt_alo14856.png" -"
> error: called from
>     __opengl_print__ at line 169 column 7
>     print at line 519 column 14
>     ganalo_php at line 125"
>
> After this happens I can not save any more images to files unless I
> restart
> Octave. I am confused and do not know were to start the debugging. Is it
> the
> fault of Octave or Ghostscript? Any help is appreciated.
>
> Cheers,
> Ignas
>
> --
> Sent from:
> http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html

Hi,

This could be related to this bug:

https://savannah.gnu.org/bugs/?func=detailitem&item_id=50686

The bug has been  closed in absence of response from previous posters, but
don't hesitate to test whether you can reproduce it.

I assume you are not using the latest Octave 5.1 since by default GS is no
more used to produce PNG files. Could you test the latest version of Octave?

Pantxo



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html