Octave 2.0.13 and Solaris 2.5.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Octave 2.0.13 and Solaris 2.5.1

Samuli Niiranen
I downloaded a binary version of Octave for Solaris 2.5.1 and am having
trouble
getting it to run. This is what happens when I try to run the program:

...
sparc4:~/src> octave
ld.so.1: octave: fatal: libF77.so.3: can't open file: errno=2
...
I think the libF77.so.3 is somekind of Fortran library ?
Please reply directly to me as I'm not subscribed to this list.


Reply | Threaded
Open this post in threaded view
|

Re: Octave 2.0.13 and Solaris 2.5.1

Martin Holz-2
Samuli Niiranen <[hidden email]> writes:

> I downloaded a binary version of Octave for Solaris 2.5.1 and am having
> trouble
> getting it to run. This is what happens when I try to run the program:
>
> ...
> sparc4:~/src> octave
> ld.so.1: octave: fatal: libF77.so.3: can't open file: errno=2
> ...
> I think the libF77.so.3 is somekind of Fortran library ?
> Please reply directly to me as I'm not subscribed to this list.

If you have libF77.so.3, you should find it in  /opt/SUNWspro/lib/.
Check if you have it and if the directory is in your $LD_LIBRARY_PATH.

However I am afraid, libF77.so is only distributed with the Sun F77
compiler, so binaries should be linked mit static Fortran libraries.  


Martin