Octave 5.1 and loading quaternion package comes back with errors

classic Classic list List threaded Threaded
3 messages Options
RT
Reply | Threaded
Open this post in threaded view
|

Octave 5.1 and loading quaternion package comes back with errors

RT

Octave 5.1 and loading quaternion package comes back with errors. I'm using Ubuntu 18.04 64bit

>> pkg install -forge quaternion
is_real_array.cc: In function ‘octave_value_list Fis_real_array(const octave_value_list&, int)’:
is_real_array.cc:49:49: warning: ‘bool octave_value::is_numeric_type() const’ is deprecated: [4.4]: use 'isnumeric' instead [-Wdeprecated-declarations]
                 || ! ((args(i).is_numeric_type () && args(i).is_real_type ())
                                                 ^
In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:728:8: note: declared here
   bool is_numeric_type (void) const
        ^~~~~~~~~~~~~~~
is_real_array.cc:49:76: warning: ‘bool octave_value::is_real_type() const’ is deprecated: [4.4]: use 'isreal' instead [-Wdeprecated-declarations]
      || ! ((args(i).is_numeric_type () && args(i).is_real_type ())
                                                                 ^

In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:708:8: note: declared here
   bool is_real_type (void) const
        ^~~~~~~~~~~~
is_real_array.cc:50:48: warning: ‘bool octave_value::is_bool_type() const’ is deprecated: [4.4]: use 'islogical' instead [-Wdeprecated-declarations]
                       || args(i).is_bool_type ()))
                                                ^
In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:701:8: note: declared here
   bool is_bool_type (void) const
        ^~~~~~~~~~~~
For information about changes from previous versions of the quaternion package, run 'news quaternion'.
>> pkg list
Package Name  | Version | Installation directory
--------------+---------+-----------------------
     control  |   3.1.0 | /home/rt/octave/control-3.1.0
     doctest  |   0.6.1 | /home/rt/octave/doctest-0.6.1
    geometry  |   3.0.0 | /home/rt/octave/geometry-3.0.0
       image  |   2.8.0 | /home/rt/octave/image-2.8.0
  quaternion  |   2.4.0 | /home/rt/octave/quaternion-2.4.0

--



Reply | Threaded
Open this post in threaded view
|

Re: Octave 5.1 and loading quaternion package comes back with errors

Doug Stewart-4


On Sun, Mar 31, 2019 at 8:29 PM RT <[hidden email]> wrote:

Octave 5.1 and loading quaternion package comes back with errors. I'm using Ubuntu 18.04 64bit

>> pkg install -forge quaternion
is_real_array.cc: In function ‘octave_value_list Fis_real_array(const octave_value_list&, int)’:
is_real_array.cc:49:49: warning: ‘bool octave_value::is_numeric_type() const’ is deprecated: [4.4]: use 'isnumeric' instead [-Wdeprecated-declarations]
                 || ! ((args(i).is_numeric_type () && args(i).is_real_type ())
                                                 ^
In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:728:8: note: declared here
   bool is_numeric_type (void) const
        ^~~~~~~~~~~~~~~
is_real_array.cc:49:76: warning: ‘bool octave_value::is_real_type() const’ is deprecated: [4.4]: use 'isreal' instead [-Wdeprecated-declarations]
      || ! ((args(i).is_numeric_type () && args(i).is_real_type ())
                                                                 ^

In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:708:8: note: declared here
   bool is_real_type (void) const
        ^~~~~~~~~~~~
is_real_array.cc:50:48: warning: ‘bool octave_value::is_bool_type() const’ is deprecated: [4.4]: use 'islogical' instead [-Wdeprecated-declarations]
                       || args(i).is_bool_type ()))
                                                ^
In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:701:8: note: declared here
   bool is_bool_type (void) const
        ^~~~~~~~~~~~
For information about changes from previous versions of the quaternion package, run 'news quaternion'.
>> pkg list
Package Name  | Version | Installation directory
--------------+---------+-----------------------
     control  |   3.1.0 | /home/rt/octave/control-3.1.0
     doctest  |   0.6.1 | /home/rt/octave/doctest-0.6.1
    geometry  |   3.0.0 | /home/rt/octave/geometry-3.0.0
       image  |   2.8.0 | /home/rt/octave/image-2.8.0
  quaternion  |   2.4.0 | /home/rt/octave/quaternion-2.4.0

--



those  are just warnings. they can be ignored.


--
DASCertificate for 206392



RT
Reply | Threaded
Open this post in threaded view
|

Re: Octave 5.1 and loading quaternion package comes back with errors

RT

Ok,  Thanks

On Sun, Mar 31, 2019 at 8:46 PM Doug Stewart <[hidden email]> wrote:


On Sun, Mar 31, 2019 at 8:29 PM RT <[hidden email]> wrote:

Octave 5.1 and loading quaternion package comes back with errors. I'm using Ubuntu 18.04 64bit

>> pkg install -forge quaternion
is_real_array.cc: In function ‘octave_value_list Fis_real_array(const octave_value_list&, int)’:
is_real_array.cc:49:49: warning: ‘bool octave_value::is_numeric_type() const’ is deprecated: [4.4]: use 'isnumeric' instead [-Wdeprecated-declarations]
                 || ! ((args(i).is_numeric_type () && args(i).is_real_type ())
                                                 ^
In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:728:8: note: declared here
   bool is_numeric_type (void) const
        ^~~~~~~~~~~~~~~
is_real_array.cc:49:76: warning: ‘bool octave_value::is_real_type() const’ is deprecated: [4.4]: use 'isreal' instead [-Wdeprecated-declarations]
      || ! ((args(i).is_numeric_type () && args(i).is_real_type ())
                                                                 ^

In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:708:8: note: declared here
   bool is_real_type (void) const
        ^~~~~~~~~~~~
is_real_array.cc:50:48: warning: ‘bool octave_value::is_bool_type() const’ is deprecated: [4.4]: use 'islogical' instead [-Wdeprecated-declarations]
                       || args(i).is_bool_type ()))
                                                ^
In file included from /app/include/octave-5.1.0/octave/../octave/ovl.h:36,
                 from /app/include/octave-5.1.0/octave/../octave/ov-fcn.h:33,
                 from /app/include/octave-5.1.0/octave/../octave/ov-builtin.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/defun-int.h:30,
                 from /app/include/octave-5.1.0/octave/../octave/defun-dld.h:32,
                 from /app/include/octave-5.1.0/octave/../octave/oct.h:32,
                 from is_real_array.cc:26:
/app/include/octave-5.1.0/octave/../octave/ov.h:701:8: note: declared here
   bool is_bool_type (void) const
        ^~~~~~~~~~~~
For information about changes from previous versions of the quaternion package, run 'news quaternion'.
>> pkg list
Package Name  | Version | Installation directory
--------------+---------+-----------------------
     control  |   3.1.0 | /home/rt/octave/control-3.1.0
     doctest  |   0.6.1 | /home/rt/octave/doctest-0.6.1
    geometry  |   3.0.0 | /home/rt/octave/geometry-3.0.0
       image  |   2.8.0 | /home/rt/octave/image-2.8.0
  quaternion  |   2.4.0 | /home/rt/octave/quaternion-2.4.0

--



those  are just warnings. they can be ignored.


--
DASCertificate for 206392



--