Octave Crush

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Octave Crush

Eran Asa
bc"d

Hi,

My Octave is crushing when I do 'clear all' 

What's the problem?

Thanks,
Eran

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave Crush

marco atzeri-2
On 11/09/2014 14:07, Eran Asa wrote:

> bc"d
>
> Hi,
>
> My Octave is crushing when I do 'clear all'
>
> What's the problem?
>
> Thanks,
> Eran

my crystal ball is broken.

It will help to know which version and build you are using
and on which operating system you are ...

Marco


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave Crush

c.-2


Il 11/set/2014 19:46 "Marco Atzeri" <[hidden email]> ha scritto:
>
> On 11/09/2014 14:07, Eran Asa wrote:
>>
>> bc"d
>>
>> Hi,
>>
>> My Octave is crushing when I do 'clear all'
>>
>> What's the problem?
>>
>> Thanks,
>> Eran
>
>
> my crystal ball is broken.
>
> It will help to know which version and build you are using
> and on which operating system you are ...

And what packages you have loaded.

> Marco

c.


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Octave Crush

Philip Nienhuis
In reply to this post by Eran Asa
Eran Asa wrote
bc"d

Hi,

My Octave is crushing when I do 'clear all'

What's the problem?
Let me guess:
- You're on Windows? using a MinGW Octave version 3.6.x?
- When you type "clear all" Octave crashes (not: "crushes")?

Well, the answer is :
Just do NOT use "clear all". Use "clear" or "clear -f",or do "help clear" to see what you can do.
Or: upgrade to 3.8.0

The "clear all" bug is a notorious one:
- http://savannah.gnu.org/bugs/?func=detailitem&item_id=40276
- http://wiki.octave.org/Octave_for_Microsoft_Windows, see under heading "Manual installation instructions for the Octave-forge packages"
It seems to be triggered only when some specific OF packages are loaded (windows, ad. ....).

With Octave-3.8.x I haven't seen it anymore.

Philip