Octave GUI location problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Octave GUI location problem

Sigfredo Pagel


Bug inform


I installed Octave 6.2 flatpak (also installed flatseal) and got an error from octave search path. Octave does not starts (from his Icon). Linux said: "do not find the package to get the following":

app/libexec/octave/6.2.0/exec/x86_64-pc-linux-gnu/octave-gui

This path does not exist, I put an annex from that but is in Spanish.

But when I follow my installed search path it really is this:

/var/lib/flatpak/app/org.octave.Octave/x86_64/stable/active/files/libexec/octave/6.2.0/exec/x86_64-pc-linux-gnu/octave-gui

I installed that for many times and the path remains the same and Octave does not starts

If anyone has a recommendation I will thank very much.

Sigfredo






ScreenSh.png (62K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Octave GUI location problem

John Frain

Are you able to start flatpak octave from the command line with

flatpak run org.octave.Octave

app/libexec/octave/6.2.0/exec/x86_64-pc-linux-gnu/octave-gui  is the address of the executable within the flatpak sandbox.  The second address is the address starting from the root directory.  They are the same file.  Running 

Octave 

from the command line will not start flatpak octave.  


Take care


John


 

John C Frain, Ph.D.

Economics Department             3 Aranleigh Park
Trinity College Dublin                 Rathfarnham
College Green                           Dublin 14
Dublin 2                                    Ireland
Ireland


On Tue, 23 Feb 2021 at 19:21, Sigfredo Pagel <[hidden email]> wrote:


Bug inform


I installed Octave 6.2 flatpak (also installed flatseal) and got an error from octave search path. Octave does not starts (from his Icon). Linux said: "do not find the package to get the following":

app/libexec/octave/6.2.0/exec/x86_64-pc-linux-gnu/octave-gui

This path does not exist, I put an annex from that but is in Spanish.

But when I follow my installed search path it really is this:

/var/lib/flatpak/app/org.octave.Octave/x86_64/stable/active/files/libexec/octave/6.2.0/exec/x86_64-pc-linux-gnu/octave-gui

I installed that for many times and the path remains the same and Octave does not starts

If anyone has a recommendation I will thank very much.

Sigfredo