Plot Error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Plot Error

Guy S. Greenwood

Hi

 

I am running Octave 3.2.4 on 2 different machines both running Windows 7 Pro 64bit.  My laptop works fine(intel i7 4GB) but alas my Desktop a DualCore does not.

 

I am doing a simple plot to check the functionality as follows

 

x = -10:0.1:10;

plot (x, sin(x))

 

On the laptop I get the sine wave as expected however the Desktop is as follows

octave-3.2.4.exe:4> x = -10:0.1:10;

octave-3.2.4.exe:5> plot (x, sin (x))

error: value on right hand side of assignment is undefined

error: called from:

error:   C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\__gnuplot_version__.m at line 33, column 23

error:   C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\__gnuplot_has_feature__.m at line 38, column 21

error:   C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\gnuplot_drawnow.m at line 229, column 11

error:   C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\gnuplot_drawnow.m at line 97, column 16

octave-3.2.4.exe:6>

 

system (sprintf ("\"%s\" --version", gnuplot_binary ())) yields

ans = -1

 

Can you please help sort this matter out

 

Guy S. Greenwood

 


_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Plot Error

Doug Stewart-4
On Wed, Dec 1, 2010 at 7:54 AM, Guy S. Greenwood
<[hidden email]> wrote:

> Hi
>
>
>
> I am running Octave 3.2.4 on 2 different machines both running Windows 7 Pro
> 64bit.  My laptop works fine(intel i7 4GB) but alas my Desktop a DualCore
> does not.
>
>
>
> I am doing a simple plot to check the functionality as follows
>
>
>
> x = -10:0.1:10;
>
> plot (x, sin(x))
>
>
>
> On the laptop I get the sine wave as expected however the Desktop is as
> follows
>
> octave-3.2.4.exe:4> x = -10:0.1:10;
>
> octave-3.2.4.exe:5> plot (x, sin (x))
>
> error: value on right hand side of assignment is undefined
>
> error: called from:
>
> error:
> C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\__gnuplot_version__.m at
> line 33, column 23
>
> error:
> C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\__gnuplot_has_feature__.m
> at line 38, column 21
>
> error:
> C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\gnuplot_drawnow.m at
> line 229, column 11
>
> error:
> C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\gnuplot_drawnow.m at
> line 97, column 16
>
> octave-3.2.4.exe:6>
>
>
>
> system (sprintf ("\"%s\" --version", gnuplot_binary ())) yields
>
> ans = -1
>
>
>
> Can you please help sort this matter out
>
>
>
> Guy S. Greenwood
>
>
>
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
>
>

It looks to me like you don't have gnuplot  in your desk top.

_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave