Potential bug

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Potential bug

Juan Pablo Carbajal
Hi,
Can anybody confirm that the following commands break the plot

frame = eye(3);
close
figure(1)
c='rgb'
for i=1:3
 line([0 frame(i,1)],[0 frame(i,2)], [0
frame(i,3)],'color',c(i),'linewidth',2);
end;
view(3)
axis equal
% So far so good, but ...
axis square
% erases two lines

Tested in 3.4.3

Thanks

--
M. Sc. Juan Pablo Carbajal
-----
PhD Student
University of Zürich
http://ailab.ifi.uzh.ch/carbajal/
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Potential bug

marco atzeri-2
On 10/21/2011 10:34 AM, Juan Pablo Carbajal wrote:

> Hi,
> Can anybody confirm that the following commands break the plot
>
> frame = eye(3);
> close
> figure(1)
> c='rgb'
> for i=1:3
>   line([0 frame(i,1)],[0 frame(i,2)], [0
> frame(i,3)],'color',c(i),'linewidth',2);
> end;
> view(3)
> axis equal
> % So far so good, but ...
> axis square
> % erases two lines
>
> Tested in 3.4.3
>
> Thanks
>
same on 3.4.2 on cygwin

Regards
Marco

_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: Potential bug

José Luis García Pallero
2011/10/21 Marco Atzeri <[hidden email]>:

> On 10/21/2011 10:34 AM, Juan Pablo Carbajal wrote:
>>
>> Hi,
>> Can anybody confirm that the following commands break the plot
>>
>> frame = eye(3);
>> close
>> figure(1)
>> c='rgb'
>> for i=1:3
>>  line([0 frame(i,1)],[0 frame(i,2)], [0
>> frame(i,3)],'color',c(i),'linewidth',2);
>> end;
>> view(3)
>> axis equal
>> % So far so good, but ...
>> axis square
>> % erases two lines
>>
>> Tested in 3.4.3
>>
>> Thanks
>>
> same on 3.4.2 on cygwin
Octave 3.4.3 compiled by myself on Debian GNU/Linux (32 bits). I send
the correct plot after 'axis equal' command and the wrong one after
'axis square' command

--
*****************************************
José Luis García Pallero
[hidden email]
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************

_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave

axis_equal.png (23K) Download Attachment
axis_square.png (30K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Potential bug

Juan Pablo Carbajal
Thanks!
I am reporting the bug.


2011/10/21 José Luis García Pallero <[hidden email]>:

> 2011/10/21 Marco Atzeri <[hidden email]>:
>> On 10/21/2011 10:34 AM, Juan Pablo Carbajal wrote:
>>>
>>> Hi,
>>> Can anybody confirm that the following commands break the plot
>>>
>>> frame = eye(3);
>>> close
>>> figure(1)
>>> c='rgb'
>>> for i=1:3
>>>  line([0 frame(i,1)],[0 frame(i,2)], [0
>>> frame(i,3)],'color',c(i),'linewidth',2);
>>> end;
>>> view(3)
>>> axis equal
>>> % So far so good, but ...
>>> axis square
>>> % erases two lines
>>>
>>> Tested in 3.4.3
>>>
>>> Thanks
>>>
>> same on 3.4.2 on cygwin
>
> Octave 3.4.3 compiled by myself on Debian GNU/Linux (32 bits). I send
> the correct plot after 'axis equal' command and the wrong one after
> 'axis square' command
>
> --
> *****************************************
> José Luis García Pallero
> [hidden email]
> (o<
> / / \
> V_/_
> Use Debian GNU/Linux and enjoy!
> *****************************************
>
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://mailman.cae.wisc.edu/listinfo/help-octave
>
>



--
M. Sc. Juan Pablo Carbajal
-----
PhD Student
University of Zürich
http://ailab.ifi.uzh.ch/carbajal/
_______________________________________________
Help-octave mailing list
[hidden email]
https://mailman.cae.wisc.edu/listinfo/help-octave