RE: [octave forge] optiminterp 0.3.6 released

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

RE: [octave forge] optiminterp 0.3.6 released

John Donoghue-3


> -----Original Message-----
> From: Windhorn, Allen E [ACIM/LSA/MKT]
> [mailto:[hidden email]]
> Sent: Monday, February 03, 2020 9:24 AM
> To: John Donoghue; [hidden email]; <[hidden email]>
> Subject: RE: [octave forge] optiminterp 0.3.6 released
>
> > -----Original Message-----
> > From: Help-octave On Behalf Of John Donoghue
> >
> > A new release of GNU Octave 'optiminterp' package is available [1]
> >
> > It is mainly a fix for the depreciated symbols for the upcoming Octave 6
> > release
> >
> > [1] https://octave.sourceforge.io/optiminterp/index.html
>
> >> pkg install -forge optiminterp
> sh: line 1:  7424 Segmentation fault      (core dumped)
> MKOCTFILE='C:/Octave/OCTAVE~1.0/mingw64/bin/mkoctfile-5.1.0.exe
> ' OCTAVE_CONFIG='C:/Octave/OCTAVE~1.0/mingw64/bin/octave-config-
> 5.1.0.exe' OCTAVE='C:/Octave/OCTAVE~1.0/mingw64/bin/oct
> ave-5.1.0.bat' ./configure CC=gcc
>
> pkg: error running the configure script for optiminterp.
> error: called from
>     configure_make at line 82 column 9
>     install at line 184 column 7
>     pkg at line 441 column 9
>
> May be nothing to do with optiminterp; I get the same for the new io pkg.
>
> Regards,
> Allen

It works without issue in 5.1.0 on my windows machine

Try running:
pkg install -verbose -forge optiminterp

It may provide more information - since you indicate it is happening also on the io package, I will assume it is not a optiminterp issue, but rather something with your install/machine

Can you create a bug report on the bug tracker
https://savannah.gnu.org/bugs/?group=octave