Re: Error in Image package in Octave

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Error in Image package in Octave

marco atzeri-2
On 10/14/2012 10:51 AM, Sivahari Nandakumar wrote:
followup to the list

> Dear Marco,
> the result of
> pkg install -verbose image-1.0.15.tar.gz
> is
>
> mkdir (/tmp/oct-FhHuOG)
> untar (/home/appu/Downloads/image-1.0.15.tar.gz, /tmp/oct-FhHuOG)
> make: mkoctfile: Command not found

you need to install the octave-devel package, otherwise you can
not compile tha package from source
(image-1.0.15.tar.gz is a source package not a binary one)


> make: *** [__spatial_filtering__.oct] Error 127
> 'make' returned the following error: make: Entering directory
> `/tmp/oct-FhHuOG/image-1.0.15/src'
> mkoctfile -Wall __spatial_filtering__.cc
> make: Leaving directory `/tmp/oct-FhHuOG/image-1.0.15/src'
> error: called from `pkg>configure_make' in file
> /usr/share/octave/3.6.2/m/pkg/pkg.m near line 1384, column 9
> error: called from:
> error:   /usr/share/octave/3.6.2/m/pkg/pkg.m at line 826, column 5
> error:   /usr/share/octave/3.6.2/m/pkg/pkg.m at line 383, column 9
>
> I copied the .m files in inst folder to image folder in
> /usr/share/octave/3.6.2/m/image, is it ok?
>
> --Sivahari

Marco



------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Octave-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/octave-dev
Reply | Threaded
Open this post in threaded view
|

Re: Error in Image package in Octave

Jordi Gutiérrez Hermoso-2
On 14 October 2012 05:12, marco atzeri <[hidden email]> wrote:

> On 10/14/2012 10:51 AM, Sivahari Nandakumar wrote:
> followup to the list
>
>> Dear Marco,
>> the result of
>> pkg install -verbose image-1.0.15.tar.gz
>> is
>>
>> mkdir (/tmp/oct-FhHuOG)
>> untar (/home/appu/Downloads/image-1.0.15.tar.gz, /tmp/oct-FhHuOG)
>> make: mkoctfile: Command not found
>
> you need to install the octave-devel package, otherwise you can
> not compile tha package from source
> (image-1.0.15.tar.gz is a source package not a binary one)

But a binary package should exist for it. I expect it would be named
something like octave-image from Sivahari's rpm or apt distribution.

We really should encourage people to install binary packages first
before we tell them to attempt to compile from source.

- Jordi G. H.

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Octave-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/octave-dev