Re: Octave-maintainers Digest, Vol 175, Issue 9

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Octave-maintainers Digest, Vol 175, Issue 9

Romanov Alexey


19:04, 4 октября 2020 г., "[hidden email]" <[hidden email]>:

Send Octave-maintainers mailing list submissions to
        [hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.gnu.org/mailman/listinfo/octave-maintainers
or, via email, send a message with subject or body 'help' to
        [hidden email]

You can reach the person managing the list at
        [hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Octave-maintainers digest..."


Today's Topics:

   1. Re: [stable build from source] Ubuntu 20.04 scintilla not
      found (JuanPi)


----------------------------------------------------------------------

Message: 1
Date: Sun, 4 Oct 2020 17:20:05 +0200
From: JuanPi <[hidden email]>
To: "John W. Eaton" <[hidden email]>
Cc: Nir Krakauer <[hidden email]>, Markus Mützel
        <[hidden email]>, Maintainers GNU Octave
        <[hidden email]>
Subject: Re: [stable build from source] Ubuntu 20.04 scintilla not
        found
Message-ID:
        <[hidden email]>
Content-Type: text/plain; charset="UTF-8"

Dear all,

The problem is finally solved.

As a last resource, I tried the reinstall method suggested to no avail.
Hence I purged of all libqt5 stuff off my system, and reinstalled the
dependencies following our wiki for 20.04.

This fixed the problem. I reckon that some old qt5 package was
blocking the correct install of some other ones (files at /usr/lib
weren't created).

Thanks to all


On Thu, Jun 18, 2020 at 3:37 PM John W. Eaton <[hidden email]> wrote:


 On 6/18/20 8:13 AM, JuanPi wrote:

 > As far as I understand these libraries are available, e.g.
 >
 > $ ldconfig -p | grep Qt5Network
 > libQt5Network.so.5 (libc6,x86-64) =>
 > /lib/x86_64-linux-gnu/libQt5Network.so.5

 I'm kind of surprised that is /lib and not /usr/lib (my Debian system
 has /usr/lib, I didn't know Ubuntu was different). In any case, do you
 also have

    /lib/x86_64-linux-gnu/libQt5Network.so

 I think that's the file the linker expects to find, not the one with the
 version number. As I understand it, ldconfig is just telling you
 whether the run-time library exists, not whether the library needed for
 linking is present.

 If that file is missing, why? It and the others should be provided by
 the qtbase5-dev (all except for Qt5Help) and qttools5-dev (Qt5Help)
 packages.

 If it is present, then why is the linker not finding it? Also if it is
 present, what is the output of

    ls -l /lib/x86_64-linux-gnu/libQt5Network.so

 (or /usr/lib/... if that's where it is)?

 The reason this is showing up as a problem with qscintilla and not Qt
 generally is that we check for qscintilla by linking a program. For the
 Qt libraries, we rely on the result of a pkg-config command. Maybe we
 should have configure double check by actually attempting to link a
 program instead of just trusting what pkg-config returns.

 > but configure is not finding them
 >
 > $ grep cannot config.log
 > /usr/bin/ld: cannot find -lpthreads

 The config.log file reports the results of all tests. Sometimes we
 check several different ways until we find something that works. So a
 "cannot find" message in the log doesn't necessarily mean that the
 feature is missing.

 jwe




--
JuanPi Carbajal
https://goo.gl/ayiJzi

-----
“An article about computational result is advertising, not
scholarship. The actual scholarship is the full software environment,
code and data, that produced the result.”
- Buckheit and Donoho



------------------------------

Subject: Digest Footer

_______________________________________________
Octave-maintainers mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/octave-maintainers


------------------------------

End of Octave-maintainers Digest, Vol 175, Issue 9
**************************************************


Отправлено из мобильной Яндекс.Почты: http://m.ya.ru/ymail