Re: transposing comma problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: transposing comma problem

mmuetzel
Am 03. Mai 2021 um 08:07 Uhr schrieb "Hamed Shakouri":

> Answers to all questions:

> * As it is shown by screenshots, is clear that I am using 6.2 (and 5.2) Editors to implement codes.
> * Certainly, I do not copy from a pdf. I am writing (typing) inside the Editor directly. 
> * error: 'chcp' undefined near line 1, column 1
> * PowerShell Output:
>
> No error.
> * Hanging when trying to recognize the character code occurs every time (several times).
>
> Thanks,
> Hamed.

IIUC, Andrew's commands were meant to be run in a *PowerShell prompt*. Not from inside Octave.

Could you please attach a short .m file that doesn't run for you?

Markus

PS: I'm moving this to the help mailing list. The maintainers mailing list is thought for discussions about Octave development.



Reply | Threaded
Open this post in threaded view
|

Re: transposing comma problem

Hamed Shakouri
Hi there,

Thank you for your help.
Yesterday I removed a few software from my laptop and reinstalled them (Anaconda, Spyder, Jupyter, ...whatever I had a problem with).
Many files related to these I deleted before reinstallation too.
It seems the problem with running the scripts/functions is resolved.
However, the character of apostrophe conveyed in files edited in version 5.2 appear in a different shape yet:
image.png
And still when I try char(<the character>) in the command line, it hangs.
The attached file is the one used to stop at the first transposing character.
 
The command chcp results in:
Active code page: 437

By the way, I suggest to the developing team to modify the line editor of the command window so that with the escape key one can delete the entire current line.
Thanks, 
Hamed.

On Sun, May 2, 2021 at 11:25 PM Markus Mützel <[hidden email]> wrote:
Am 03. Mai 2021 um 08:07 Uhr schrieb "Hamed Shakouri":
> Answers to all questions:

> * As it is shown by screenshots, is clear that I am using 6.2 (and 5.2) Editors to implement codes.
> * Certainly, I do not copy from a pdf. I am writing (typing) inside the Editor directly. 
> * error: 'chcp' undefined near line 1, column 1
> * PowerShell Output:
>
> No error.
> * Hanging when trying to recognize the character code occurs every time (several times).
>
> Thanks,
> Hamed.

IIUC, Andrew's commands were meant to be run in a *PowerShell prompt*. Not from inside Octave.

Could you please attach a short .m file that doesn't run for you?

Markus

PS: I'm moving this to the help mailing list. The maintainers mailing list is thought for discussions about Octave development.



--

With Regards,

Hamed Shakouri G.



IC_Plot.m (454 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: transposing comma problem

mmuetzel
Am 03. Mai 2021 um 19:04 Uhr schrieb "Hamed Shakouri":
> Hi there,

> Thank you for your help.
> Yesterday I removed a few software from my laptop and reinstalled them (Anaconda, Spyder, Jupyter, ...whatever I had a problem with).
> Many files related to these I deleted before reinstallation too.
> It seems the problem with running the scripts/functions is resolved.

Do I understand correctly that the problem with the single quote character disappeared, and it is working correctly for you now?

> However, the character of apostrophe conveyed in files edited in version 5.2 appear in a different shape yet:

Maybe try a different font if you don't like the one you are using currently.

> And still when I try char(<the character>) in the command line, it hangs.

Could you please explain which character you enter that causes the hang? What is your keyboard layout and OS locale? Which (combination of) keys do you press?

> The attached file is the one used to stop at the first transposing character.

I don't have some of the functions that are used in that script. But other than that, the file looks ok to me.

> The command chcp results in:
> Active code page: 437

> By the way, I suggest to the developing team to modify the line editor of the command window so that with the escape key one can delete the entire current line.
> Thanks, 
> Hamed. 





Reply | Threaded
Open this post in threaded view
|

Re: transposing comma problem

mmuetzel
Am 04. Mai 2021 um 00:01 Uhr schrieb "Hamed Shakouri":
>
> >  Maybe try a different font if you don't like the one you are using currently.

> * The problem is not the font. The character is typed in 5.2 (apostrophe - the key next to Enter). It appears vertically in both 5.2 and 6.2, but when I open a file created in 5.2 by 6.2, it appears slant.  It causes the command window to hang when moved there. However, while it looks ok when running the script, apparently, 6.2 editor does not recognize it as a quoting character.

Repeating again: What is your keyboard layout and OS locale?

If you open the editor preferences in Octave and scroll down, which text encoding is selected? Which fonts are set in the editor styles block?

Markus