Updated: octave-forge-2005.06.13-3

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Updated: octave-forge-2005.06.13-3

James R. Phillips-3
INFO
====
The cygwin octave-forge package has been updated to release 2005.06.13-3.

There was a corrupted version of this upload that existed briefly on the
mirrors as octave-forge-2005.06.13-2; if you installed this, you definitely
need to update.

Changes:

 +Links with --enable-auto-image-base flag to reduce need for rebasing dlls
 +Supports (and requires) cygwin gsl package
 +New build script builds out-of-tree using shtool-mkshadow

More information in the octave-forge-2005.06.13-3.README file.

The octave-forge project contains over 500 contributed functions for GNU Octave
which are not in the main distribution. These functions are grouped according
to the following subdirectories: audio, comm, control, general, geometry,
ident, image, io, linear-algebra, miscellaneous, optim, path, plot, set,
signal, sparse, specfun, special-matrix, splines, statistics, strings, struct,
symbolic, time. The Cygwin distribution of octave-forge also incorporates
m-files from the octave-ci collection.

octave-forge home page: http://octave.sourceforge.net

octave-ci collection: ftp://ftp.ci.tuwien.ac.at/pub/octave/octave-ci.tar.gz



UPDATE
======

To update your installation, click on the "Install Cygwin now" link on the
http://cygwin.com/ web page.  This downloads setup.exe to your system.  Save it
and run setup, answer the questions and pick up 'octave-forge' from the 'Math'
category. Then click on the 'skip' field next to 'octave-forge' until
'2005.06.13-2' is
displayed.

DOWNLOAD:
=========
Note that downloads from sources.redhat.com (aka cygwin.com) aren't allowed due
to bandwidth limitations.  This means that you will need to find a mirror which
has this update, please choose the one nearest to you:

http://cygwin.com/mirrors.html


QUESTIONS:
==========
If you want to make a point or ask a question the Cygwin mailing list is the
appropriate place.


CYGWIN-ANNOUNCE UNSUBSCRIBE INFO:
=================================
To unsubscribe to the cygwin-announce mailing list, look at the
"List-Unsubscribe: " tag in the email header of this message.  Send email to
the address specified there.  It will be in the format:

cygwin-announce-unsubscribe-YOU=[hidden email]

If you need more information on unsubscribing, start reading here:

http://sources.redhat.com/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
starting at this URL.

MAINTAINER
==========
James R. Phillips




Reply | Threaded
Open this post in threaded view
|

RE: Updated: octave-forge-2005.06.13-3

Paul Billings
James,

I am installing from the octave-forge-2005.06.13-3 copy from
mirrors.kernel.org and I get a number of occurrences of:
"error: unknown (or unsupported) file type `K'"
This is when installing the various scripts.  For example:
  /usr/share/octave/2.1.71/site/m/octave-forge/octave-ci/misc/

Ignoring allows installation to continue.  There were perhaps 15 (?)
occurrences.

Paul


> -----Original Message-----
> From: James R. Phillips [mailto:[hidden email]]
> Sent: Monday, August 15, 2005 4:58 AM
> To: [hidden email]
> Cc: [hidden email]; [hidden email]
> Subject: Updated: octave-forge-2005.06.13-3
>
>
> INFO
> ====
> The cygwin octave-forge package has been updated to release 2005.06.13-3.

Reply | Threaded
Open this post in threaded view
|

RE: Updated: octave-forge-2005.06.13-3

James R. Phillips-2


--- "Billings, Paul" <[hidden email]> wrote:

> James,
>
> I am installing from the octave-forge-2005.06.13-3 copy from
> mirrors.kernel.org and I get a number of occurrences of:
> "error: unknown (or unsupported) file type `K'"
> This is when installing the various scripts.  For example:
>   /usr/share/octave/2.1.71/site/m/octave-forge/octave-ci/misc/
>
> Ignoring allows installation to continue.  There were perhaps 15 (?)
> occurrences.
>
> Paul
>
>
> > -----Original Message-----
> > From: James R. Phillips [mailto:[hidden email]]
> > Sent: Monday, August 15, 2005 4:58 AM
> > To: [hidden email]
> > Cc: [hidden email]; [hidden email]
> > Subject: Updated: octave-forge-2005.06.13-3
> >
> >
> > INFO
> > ====
> > The cygwin octave-forge package has been updated to release 2005.06.13-3.
>
>

Reply | Threaded
Open this post in threaded view
|

RE: Updated: octave-forge-2005.06.13-3

James R. Phillips-2
In reply to this post by Paul Billings
--- "Billings, Paul"  wrote:

> James,
>
> I am installing from the octave-forge-2005.06.13-3 copy from
> mirrors.kernel.org and I get a number of occurrences of:
> "error: unknown (or unsupported) file type `K'"
> This is when installing the various scripts.  For example:
>   /usr/share/octave/2.1.71/site/m/octave-forge/octave-ci/misc/
>
> Ignoring allows installation to continue.  There were perhaps 15 (?)
> occurrences.
>
> Paul
>

Sorry my earlier reply to this was garbled.

This issue has been fixed, resulting in octave-forge-2005.06.13-4.  Please try
this and ask for help on the [hidden email] mailing list if there are any
other issues.


Reply | Threaded
Open this post in threaded view
|

Re: Updated: octave-forge-2005.06.13-3

James R. Phillips-2
In reply to this post by James R. Phillips-3
--- Paul Kienzle  wrote:

> Please make sure necessary patches get into the upstream source.
>
> - Paul
>

This was a packaging problem, introduced by my use of shtool-mkshadow to build
a shadow source tree, allowing the package to build out-of-tree, and making it
thereby more compatible with the cygwin generic-build-script.

There are no source patches necessary, as the problem was in the build script.

Jim Phillips