Windows7, Octave 5.1.0, unable to install package "Signal"

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Windows7, Octave 5.1.0, unable to install package "Signal"

UgoP
Hello everyone,

I'm currently unable to install the package "signal" over Octave 5.1.0
running on Windows7 PRO.
I was on the contrary able to install :

>> pkg list
Package Name        | Version | Installation directory
--------------------+---------+-----------------------
           control  |   3.2.0 |
...\Octave-5.1.0.0\mingw64\share\octave\packages\control-3.2.0
instrument-control  |   0.4.0 |
...\mingw64\share\octave\packages\instrument-control-0.4.0

After having downloaded the signal package, the installation ends with the
following error message :

>> pkg install -forge signal
mv: cannot move
'C:/Octave/Octave-5.1.0.0/mingw64/share/octave/packages/signal-1.4.1/x86_64-w64-m
ingw32-api-v53/cl2bp.oct' to
'C:/Octave/Octave-5.1.0.0/mingw64/lib/octave/packages/signal-1.4.1/x
86_64-w64-mingw32-api-v53/cl2bp.oct': Device or resource busy
mv: cannot move
'C:/Octave/Octave-5.1.0.0/mingw64/share/octave/packages/signal-1.4.1/x86_64-w64-m
ingw32-api-v53/medfilt1.oct' to
'C:/Octave/Octave-5.1.0.0/mingw64/lib/octave/packages/signal-1.4.
1/x86_64-w64-mingw32-api-v53/medfilt1.oct': Device or resource busy
couldn't copy files to the installation directory
error: called from
    install>copy_files at line 545 column 9
    install at line 219 column 7
    pkg at line 441 column 9

I have also tried to run Octave as administrator, but it doesn't help.

Any suggestion will be appreciated.
Thank-you, best regards

Ugo



--
Sent from: http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: Windows7, Octave 5.1.0, unable to install package "Signal"

siko1056
On 6/30/19 8:25 PM, UgoP wrote:

> Hello everyone,
>
> I'm currently unable to install the package "signal" over Octave 5.1.0
> running on Windows7 PRO.
> I was on the contrary able to install :
>
>>> pkg list
> Package Name        | Version | Installation directory
> --------------------+---------+-----------------------
>            control  |   3.2.0 |
> ...\Octave-5.1.0.0\mingw64\share\octave\packages\control-3.2.0
> instrument-control  |   0.4.0 |
> ...\mingw64\share\octave\packages\instrument-control-0.4.0
>
> After having downloaded the signal package, the installation ends with the
> following error message :
>
>>> pkg install -forge signal
> mv: cannot move
> 'C:/Octave/Octave-5.1.0.0/mingw64/share/octave/packages/signal-1.4.1/x86_64-w64-m
> ingw32-api-v53/cl2bp.oct' to
> 'C:/Octave/Octave-5.1.0.0/mingw64/lib/octave/packages/signal-1.4.1/x
> 86_64-w64-mingw32-api-v53/cl2bp.oct': Device or resource busy
> mv: cannot move
> 'C:/Octave/Octave-5.1.0.0/mingw64/share/octave/packages/signal-1.4.1/x86_64-w64-m
> ingw32-api-v53/medfilt1.oct' to
> 'C:/Octave/Octave-5.1.0.0/mingw64/lib/octave/packages/signal-1.4.
> 1/x86_64-w64-mingw32-api-v53/medfilt1.oct': Device or resource busy
> couldn't copy files to the installation directory
> error: called from
>     install>copy_files at line 545 column 9
>     install at line 219 column 7
>     pkg at line 441 column 9
>
> I have also tried to run Octave as administrator, but it doesn't help.
>
> Any suggestion will be appreciated.
> Thank-you, best regards
>
> Ugo


Dear Ugo,

Please note that many Octave Forge packages are already included with
all versions of the official Windows release.

   https://wiki.octave.org/Octave_for_Microsoft_Windows#Packages

So signal (version 1.4.0).  Do you need version 1.4.1 for some specific
reason?  Otherwise just type

   pkg load signal

after starting a freshly installed Octave to make use of that package.

Best,
Kai