can't run Octave

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

can't run Octave

Octave - General mailing list
Dear Octave,

I am trying to load Octave onto my computer. According to the Control Panel, the system is Windows Home 10 and the System type is "64-bit Operating System, x64-based processor." I used the installer "octave-5.2.0_1-w64-installer.exe (~ 300 MB) [signature]" which I downloaded from "https://www.gnu.org/software/octave/download.html" and I used the default parameters.

The installer created two icons, "GNU Octave (GUI)" with a target "%SYSTEMROOT%\system32\wscript.exe "C:\Octave\Octave-5.2.0\octave.vbs" --gui" and "GNU Octave (CLI)" with a target "%SYSTEMROOT%\system32\wscript.exe "C:\Octave\Octave-5.2.0\octave.vbs" --no-gui.

Nothing seems to happen when I double click on either icon.

The installer created files "C:\Octave\Octave-5.2.0\octave.vbs" and "C:\Octave\Octave-5.2.0\octave-firsttime.vbs," but nothing seems to happen when I click on either of them.

I have tried uninstalling and reinstalling twice, and the same thing happens.

How do I actually run the program?

Thank you,
Finley Shapiro





Reply | Threaded
Open this post in threaded view
|

Re: can't run Octave

nrjank
Administrator
On Fri, Jun 12, 2020 at 4:39 PM FINLEY SHAPIRO via Help-octave <[hidden email]> wrote:
Dear Octave,

I am trying to load Octave onto my computer. According to the Control Panel, the system is Windows Home 10 and the System type is "64-bit Operating System, x64-based processor." I used the installer "octave-5.2.0_1-w64-installer.exe (~ 300 MB) [signature]" which I downloaded from "https://www.gnu.org/software/octave/download.html" and I used the default parameters.

The installer created two icons, "GNU Octave (GUI)" with a target "%SYSTEMROOT%\system32\wscript.exe "C:\Octave\Octave-5.2.0\octave.vbs" --gui" and "GNU Octave (CLI)" with a target "%SYSTEMROOT%\system32\wscript.exe "C:\Octave\Octave-5.2.0\octave.vbs" --no-gui.

Nothing seems to happen when I double click on either icon.

The installer created files "C:\Octave\Octave-5.2.0\octave.vbs" and "C:\Octave\Octave-5.2.0\octave-firsttime.vbs," but nothing seems to happen when I click on either of them.

I have tried uninstalling and reinstalling twice, and the same thing happens.

How do I actually run the program?


Normally, nothing more than you've already done.  When you say 'when i click on either of them' do you mean the .vbs files or the shortcuts on the desktop? 

Is your security software reporting anything being blocked? Are you able to run vbs files with wscript? some anti-malware tools have vbs script blocking as an option.

Have you tried the zip packages instead of the executable, downloadable from the same location?  Try uninstalling octave, then download the zip package and follow the discussion at: https://wiki.octave.org/Octave_for_Microsoft_Windows

please let us know if any of that helps. 


Reply | Threaded
Open this post in threaded view
|

Re: can't run Octave

Octave - General mailing list
I opened the vbs files, and I was able to figure out that it has a call to the file C:\Octave\Octave-5.2.0\mingw64\bin\octave-gui.exe. I found this file in Windows Explorer, and I was able to double click on it and run the program. I also created a shortcut directly to it. I may not be able to adjust some of the parameters, but so far I am able to do what I need to.

I don't know much about system commands in Windows, but the commands in the vbs files look a lot like Unix commands that I've never seen in Windows.

On Friday, June 12, 2020, 05:08:00 PM EDT, Nicholas Jankowski <[hidden email]> wrote:


On Fri, Jun 12, 2020 at 4:39 PM FINLEY SHAPIRO via Help-octave <[hidden email]> wrote:
Dear Octave,

I am trying to load Octave onto my computer. According to the Control Panel, the system is Windows Home 10 and the System type is "64-bit Operating System, x64-based processor." I used the installer "octave-5.2.0_1-w64-installer.exe (~ 300 MB) [signature]" which I downloaded from "https://www.gnu.org/software/octave/download.html" and I used the default parameters.

The installer created two icons, "GNU Octave (GUI)" with a target "%SYSTEMROOT%\system32\wscript.exe "C:\Octave\Octave-5.2.0\octave.vbs" --gui" and "GNU Octave (CLI)" with a target "%SYSTEMROOT%\system32\wscript.exe "C:\Octave\Octave-5.2.0\octave.vbs" --no-gui.

Nothing seems to happen when I double click on either icon.

The installer created files "C:\Octave\Octave-5.2.0\octave.vbs" and "C:\Octave\Octave-5.2.0\octave-firsttime.vbs," but nothing seems to happen when I click on either of them.

I have tried uninstalling and reinstalling twice, and the same thing happens.

How do I actually run the program?


Normally, nothing more than you've already done.  When you say 'when i click on either of them' do you mean the .vbs files or the shortcuts on the desktop? 

Is your security software reporting anything being blocked? Are you able to run vbs files with wscript? some anti-malware tools have vbs script blocking as an option.

Have you tried the zip packages instead of the executable, downloadable from the same location?  Try uninstalling octave, then download the zip package and follow the discussion at: https://wiki.octave.org/Octave_for_Microsoft_Windows

please let us know if any of that helps.