control-3.2.0.tar.gz installation problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
SGM
Reply | Threaded
Open this post in threaded view
|

control-3.2.0.tar.gz installation problem

SGM
Hi,

I am trying to install control package and I am facing following problem:
⶜몍>> pkg install control-3.2.0.tar.gz
warning: LFLAGS is deprecated and will be removed in a future version of
Octave, use LDFLAGS instead
MA02ID.f:188:21:

  184 |          DO 90 J = 1, N+1
      |                                                                      
2
......
  188 |                DWORK(J-1) = DWORK(J-1) + TEMP
      |                     1
Warning: Array reference at (1) out of bounds (0 < 1) in loop beginning at
(2)
MA02ID.f:188:34:

  184 |          DO 90 J = 1, N+1
      |                                                                      
2
......
  188 |                DWORK(J-1) = DWORK(J-1) + TEMP
      |                                  1
Warning: Array reference at (1) out of bounds (0 < 1) in loop beginning at
(2)
MA02ID.f:230:21:

  226 |          DO 160 J = 1, N+1
      |                                                                      
2
......
  230 |                DWORK(J-1) = DWORK(J-1) + TEMP
      |                     1
Warning: Array reference at (1) out of bounds (0 < 1) in loop beginning at
(2)
MA02ID.f:230:34:

  226 |          DO 160 J = 1, N+1
      |                                                                      
2
......
  230 |                DWORK(J-1) = DWORK(J-1) + TEMP
      |                                  1
Warning: Array reference at (1) out of bounds (0 < 1) in loop beginning at
(2)
warning: LFLAGS is deprecated and will be removed in a future version of
Octave, use LDFLAGS instead
couldn't delete directory
C:\Octave\OCTAVE~1.0\mingw64\share\octave\packages\control-3.1.0: Permission
denied
error: called from
    uninstall at line 120 column 11
    install at line 205 column 9
    pkg at line 441 column 9

Request help for resolution.

Regards



--
Sent from: https://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: control-3.2.0.tar.gz installation problem

Octave - General mailing list
On Mon, 2020-11-09 at 22:12 -0600, SGM wrote:

> Hi,
>
> I am trying to install control package and I am facing following
> problem:
> ⶜몍>> pkg install control-3.2.0.tar.gz
> warning: LFLAGS is deprecated and will be removed in a future version
> of
> Octave, use LDFLAGS instead
> MA02ID.f:188:21:
>
>   184 |          DO 90 J = 1, N+1
>       |                                                              
>        
> 2
> ......
>   188 |                DWORK(J-1) = DWORK(J-1) + TEMP
>       |                     1
> Warning: Array reference at (1) out of bounds (0 < 1) in loop
> beginning at
> (2)
> MA02ID.f:188:34:
>
>   184 |          DO 90 J = 1, N+1
>       |                                                              
>        
> 2
> ......
>   188 |                DWORK(J-1) = DWORK(J-1) + TEMP
>       |                                  1
> Warning: Array reference at (1) out of bounds (0 < 1) in loop
> beginning at
> (2)
> MA02ID.f:230:21:
>
>   226 |          DO 160 J = 1, N+1
>       |                                                              
>        
> 2
> ......
>   230 |                DWORK(J-1) = DWORK(J-1) + TEMP
>       |                     1
> Warning: Array reference at (1) out of bounds (0 < 1) in loop
> beginning at
> (2)
> MA02ID.f:230:34:
>
>   226 |          DO 160 J = 1, N+1
>       |                                                              
>        
> 2
> ......
>   230 |                DWORK(J-1) = DWORK(J-1) + TEMP
>       |                                  1
> Warning: Array reference at (1) out of bounds (0 < 1) in loop
> beginning at
> (2)
> warning: LFLAGS is deprecated and will be removed in a future version
> of
> Octave, use LDFLAGS instead
> couldn't delete directory
> C:\Octave\OCTAVE~1.0\mingw64\share\octave\packages\control-3.1.0:
> Permission
> denied
> error: called from
>     uninstall at line 120 column 11
>     install at line 205 column 9
>     pkg at line 441 column 9
>
> Request help for resolution.
>
> Regards
>

The warnings on deprecated LFLAGS are already fixed in a development
branch in the package's hg repositorium.

The core problem that prevents a successful installation is the missing
permissions for the install directory of your currently installed
control package 3.1.0
(C:\Octave\OCTAVE~1.0\mingw64\share\octave\packages\control-3.1.0).
Could you try to install the packages as administrator?

Best regards
Torsten



Reply | Threaded
Open this post in threaded view
|

Re: control-3.2.0.tar.gz installation problem

mmuetzel
Am 10. November 2020 um 07:25 Uhr schrieb "Torsten Lilge via Help-octave":
> On Mon, 2020-11-09 at 22:12 -0600, SGM wrote:
> > Hi,
> >
> > I am trying to install control package and I am facing following
> > problem:
[...]

> > couldn't delete directory
> > C:\Octave\OCTAVE~1.0\mingw64\share\octave\packages\control-3.1.0:
> > Permission
> > denied
> > error: called from
> >     uninstall at line 120 column 11
> >     install at line 205 column 9
> >     pkg at line 441 column 9
> >
> > Request help for resolution.
> >
> > Regards
> >
>
> The warnings on deprecated LFLAGS are already fixed in a development
> branch in the package's hg repositorium.
>
> The core problem that prevents a successful installation is the missing
> permissions for the install directory of your currently installed
> control package 3.1.0
> (C:\Octave\OCTAVE~1.0\mingw64\share\octave\packages\control-3.1.0).
> Could you try to install the packages as administrator?
>
> Best regards
> Torsten
>

Alternatively, you could try installing it as a local package:
pkg install -local control-3.2.0.tar.gz

Or you could use GNU Octave 5.2.0 for Windows which already includes control 3.2.0.

HTH,
Markus


Reply | Threaded
Open this post in threaded view
|

Re: control-3.2.0.tar.gz installation problem

mmuetzel
Am 10. November 2020 um 11:59 Uhr schrieb "swagata Mukherjee":
> Hi Markus,
> Thanks. Re-Installed 5.2.0 and resolved.
>  
> Regards,
> Swagata 

I'm happy this worked for you.

Please, keep the mailing list in CC so that others know your issue is resolved.

Regards,
Markus