flex version

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

flex version

Lippert, Ross A.

In a recent build from the CVS I found otu I needed flex 2.5.4 or higher.
This is clear because of a test that goes on in octave/src/lex.l on some
macros:
FLEX_SCANNER
YY_FLEX_MAJOR_VERSION
YY_FLEX_MINOR_VERSION

I am not sure what config program sets these variables.


Anyhow, bottom line is I should not have to alerted of this in the
middle of the make, which currently I am.  I should be told of the
incorrect version during ./configure, right?



-r

-----Original Message-----
From: John W. Eaton [mailto:[hidden email]]
Sent: Friday, October 27, 2000 3:36 PM
To: Lippert, Ross A.
Subject: RE: weirdness of Dec alphas


On 27-Oct-2000, Lippert, Ross A. <[hidden email]> wrote:

| OK, so let me get this straight:
|
| The best way for me to fix my alpha problem

I don't know what the best fix is.  I still don't know what the
problem is.  Your first report of a problem (other than the lapack
one) simply said that

  BTW oct-time.cc has some trouble in it (checking whether something
  is defined instead of whether something is false, preventing a compile
  on the dec alpha).  If it hasn't been fixed yet I'll send an easy
  patch for it.

Look at it from my point of view.  This is really vague, so how can I
fix it?  You don't even say what version of Octave you are using.  I
guessed latest 2.1.x or CVS since you sent your first message to
octave-maintainers, in which case I don't think it is unreasonable to
ask you to take a look at the CVS archive.  Now you are saying

  BTW I checked the latest liboctave/oct-time.cc and it really does need
lines
  of the form

  #ifdef (HAVE_TM_ZONE)
  #if (!HAVE_TM_ZONE)
  #undef HAVE_TM_ZONE
  #end if
  #end if

which is a bit more specific, but it still doesn't tell me enough to
know why I should make any change like this.  What problem is it
trying to solve?

jwe


Reply | Threaded
Open this post in threaded view
|

flex version

John W. Eaton-6
[I sent a similar reply directly to Ross before noticing that his
message was cc:'d to the list. --jwe]

On 27-Oct-2000, Lippert, Ross A. <[hidden email]> wrote:

| In a recent build from the CVS I found otu I needed flex 2.5.4 or higher.
| This is clear because of a test that goes on in octave/src/lex.l on some
| macros:
| FLEX_SCANNER
| YY_FLEX_MAJOR_VERSION
| YY_FLEX_MINOR_VERSION
|
| I am not sure what config program sets these variables.

They are defined by flex.

| Anyhow, bottom line is I should not have to alerted of this in the
| middle of the make, which currently I am.  I should be told of the
| incorrect version during ./configure, right?

It would be better, but it was easier to just make the check in lex.l
using flex macros.

jwe


Reply | Threaded
Open this post in threaded view
|

flex version

John W. Eaton-6
On 27-Oct-2000, I wrote:

| It would be better, but it was easier to just make the check in lex.l
| using flex macros.

Thinking about it a bit more, I'm not sure that it is worth writing a
configure check for this if you are just going to check the version
number, since what is really needed is a check to make sure that flex
has the required feature(s) or doesn't have the bug(s) that prompted
me to require 2.5.4.  Unfortunately, I don't have a record of that,
only the following lame-o ChangeLog entry, which doesn't help much.

  Fri Feb 21 15:35:18 1997  John W. Eaton  <[hidden email]>

          * lex.l: Require flex 2.5 or later (we really want 2.5.4 or later,
          but there seems to be no good way to check the patchlevel).

jwe