hdf5.h doesn't found

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

hdf5.h doesn't found

José Luis García Pallero


Hello:

I'm trying to compile Octave 3.8.2 in Debian Sid. I've done the
./configure step as

./configure --prefix=/opt/octave CFLAGS=-O2 CXXFLAGS=-O2 FFLAGS=-O2
--with-hdf5-includedir=/usr/include/hdf5/serial/
--with-hdf5-libdir=/usr/lib/x86_64-linux-gnu/hdf5/serial/

I've installed the Debian packages libhdf5-8, libhdf5-cpp-8 and
libhdf5-dev. In /usr/include/hdf5/serial/ I can see the hdf5.h file
and in /usr/lib/x86_64-linux-gnu/hdf5/serial/ there are libhdf5.a|so
et al. I obtain this error at compile time:

g++ -E -DHAVE_CONFIG_H -I. -I..  \
  -I../liboctave/cruft/misc -I../liboctave/array
-I../liboctave/numeric -I../liboctave/numeric -I../liboctave/operators
-I../liboctave/operators -I../liboctave/system -I../liboctave/util
-I./octave-value -I./operators -Iparse-tree -I./parse-tree -Icorefcn
-I./corefcn -I../libgnu -I../libgnu   \
   -Wall -W -Wshadow -Wold-style-cast -Wformat -Wpointer-arith
-Wwrite-strings -Wcast-align -Wcast-qual -O2 -pthread \
  -DMAKE_BUILTINS octave.cc > octave.df-t
In file included from ./octave-value/ov.h:42:0,
                 from corefcn/Cell.h:32,
                 from octave.cc:52:
corefcn/oct-hdf5.h:27:18: fatal error: hdf5.h: No existe el fichero o
el directorio
 #include <hdf5.h>
                  ^
compilation terminated.
Makefile:8536: recipe for target 'octave.df' failed

The compiler says hdf5.h was not found. Is it a bug or is may
./configure step wrong? ./configure didn't emit any warning about. The
HDF5 related lines were:

  HDF5 CPPFLAGS:               -I/usr/include/hdf5/serial/
  HDF5 LDFLAGS:                -L/usr/lib/x86_64-linux-gnu/hdf5/serial/
  HDF5 libraries:              -lhdf5


Thanks

--
*****************************************
José Luis García Pallero
<a href="javascript:;" onclick="_e(event, &#39;cvml&#39;, &#39;jgpallero@gmail.com&#39;)">jgpallero@...
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************



--
*****************************************
José Luis García Pallero
[hidden email]
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************
Reply | Threaded
Open this post in threaded view
|

Re: hdf5.h doesn't found

John W. Eaton
Administrator
On 02/25/2015 05:47 PM, José Luis García Pallero wrote:

>
>
> Hello:
>
> I'm trying to compile Octave 3.8.2 in Debian Sid. I've done the
> ./configure step as
>
> ./configure --prefix=/opt/octave CFLAGS=-O2 CXXFLAGS=-O2 FFLAGS=-O2
> --with-hdf5-includedir=/usr/include/hdf5/serial/
> --with-hdf5-libdir=/usr/lib/x86_64-linux-gnu/hdf5/serial/
>
> I've installed the Debian packages libhdf5-8, libhdf5-cpp-8 and
> libhdf5-dev. In /usr/include/hdf5/serial/ I can see the hdf5.h file
> and in /usr/lib/x86_64-linux-gnu/hdf5/serial/ there are libhdf5.a|so
> et al. I obtain this error at compile time:
>
> g++ -E -DHAVE_CONFIG_H -I. -I..  \
>    -I../liboctave/cruft/misc -I../liboctave/array
> -I../liboctave/numeric -I../liboctave/numeric -I../liboctave/operators
> -I../liboctave/operators -I../liboctave/system -I../liboctave/util
> -I./octave-value -I./operators -Iparse-tree -I./parse-tree -Icorefcn
> -I./corefcn -I../libgnu -I../libgnu   \
>     -Wall -W -Wshadow -Wold-style-cast -Wformat -Wpointer-arith
> -Wwrite-strings -Wcast-align -Wcast-qual -O2 -pthread \
>    -DMAKE_BUILTINS octave.cc > octave.df-t
> In file included from ./octave-value/ov.h:42:0,
>                   from corefcn/Cell.h:32,
>                   from octave.cc:52:
> corefcn/oct-hdf5.h:27:18: fatal error: hdf5.h: No existe el fichero o
> el directorio
>   #include <hdf5.h>
>                    ^
> compilation terminated.
> Makefile:8536: recipe for target 'octave.df' failed
>
> The compiler says hdf5.h was not found. Is it a bug or is may
> ./configure step wrong? ./configure didn't emit any warning about. The
> HDF5 related lines were:

I'm pretty sure this is a bug in the Makefiles that has since been fixed.

As a quick workaround, try running configure with

   configure ... CPPFLAGS=-I... LDFLAGS=-L...

instead of using the --with-hdf5-... options.

jwe



Reply | Threaded
Open this post in threaded view
|

Re: hdf5.h doesn't found

José Luis García Pallero
2015-02-26 2:02 GMT+01:00 John W. Eaton <[hidden email]>:

> On 02/25/2015 05:47 PM, José Luis García Pallero wrote:
>>
>>
>>
>> Hello:
>>
>> I'm trying to compile Octave 3.8.2 in Debian Sid. I've done the
>> ./configure step as
>>
>> ./configure --prefix=/opt/octave CFLAGS=-O2 CXXFLAGS=-O2 FFLAGS=-O2
>> --with-hdf5-includedir=/usr/include/hdf5/serial/
>> --with-hdf5-libdir=/usr/lib/x86_64-linux-gnu/hdf5/serial/
>>
>> I've installed the Debian packages libhdf5-8, libhdf5-cpp-8 and
>> libhdf5-dev. In /usr/include/hdf5/serial/ I can see the hdf5.h file
>> and in /usr/lib/x86_64-linux-gnu/hdf5/serial/ there are libhdf5.a|so
>> et al. I obtain this error at compile time:
>>
>> g++ -E -DHAVE_CONFIG_H -I. -I..  \
>>    -I../liboctave/cruft/misc -I../liboctave/array
>> -I../liboctave/numeric -I../liboctave/numeric -I../liboctave/operators
>> -I../liboctave/operators -I../liboctave/system -I../liboctave/util
>> -I./octave-value -I./operators -Iparse-tree -I./parse-tree -Icorefcn
>> -I./corefcn -I../libgnu -I../libgnu   \
>>     -Wall -W -Wshadow -Wold-style-cast -Wformat -Wpointer-arith
>> -Wwrite-strings -Wcast-align -Wcast-qual -O2 -pthread \
>>    -DMAKE_BUILTINS octave.cc > octave.df-t
>> In file included from ./octave-value/ov.h:42:0,
>>                   from corefcn/Cell.h:32,
>>                   from octave.cc:52:
>> corefcn/oct-hdf5.h:27:18: fatal error: hdf5.h: No existe el fichero o
>> el directorio
>>   #include <hdf5.h>
>>                    ^
>> compilation terminated.
>> Makefile:8536: recipe for target 'octave.df' failed
>>
>> The compiler says hdf5.h was not found. Is it a bug or is may
>> ./configure step wrong? ./configure didn't emit any warning about. The
>> HDF5 related lines were:
>
>
> I'm pretty sure this is a bug in the Makefiles that has since been fixed.
>
> As a quick workaround, try running configure with
>
>   configure ... CPPFLAGS=-I... LDFLAGS=-L...
>
> instead of using the --with-hdf5-... options.

Thanks. It works

>
> jwe
>
>



--
*****************************************
José Luis García Pallero
[hidden email]
(o<
/ / \
V_/_
Use Debian GNU/Linux and enjoy!
*****************************************