mkoctfile not working

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

mkoctfile not working

Jeff Mason-2
I cant get mkoctfile to work - Im using Octave 2.0.5 on
sparc-sun-solaris2.5.1 . I configured with --with_f2c
and I do see -DWITH_DYNAMIC_LINKING=1. With the original
mkoctfile script I got thousands of error messages from
the last line of the script (linking). I removed the
-shared option and then got only a few undefined syms
like "dlopen" and "dlclose" so I changed the definition
LIBDLFCN="" to LIBDLFCN="-ldl" and then was only getting
MAIN__ undefined. I have tried putting -u MAIN__ in
several places such as:

$CXX -u MAIN__ -o $octfile $objfile $LIBFLAGS $RLD_FLAG $OCTAVE_LIBS $FLIBS $LEXLIB $TERMLIBS $LIBS -u MAIN__

,as well as CPPFLAGS=" -u MAIN__", but I still get:

112 jjmason@sass1905:ex % mkoctfile hello.cc
making hello.o from hello.cc
making hello.oct from hello.o
Undefined                       first referenced
 symbol                             in file
MAIN__                              (command line)
ld: fatal: Symbol referencing errors. No output written to hello.oct
113 jjmason@sass1905:ex %

I dont know if Im on the right track here or just thrashing.
Any suggestions?

Thanks -- Jeff

Jeff Mason               |     Radar Analysis Dept.
Mail Stop 0537           |     Dept. Number 2344
Sandia National Labs     |     [hidden email]
PO Box 5800              |     phone (505) 845-8565
Albuquerque, NM 87106    |     FAX (505) 845-9888