mpi package won't install on 4.0

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

mpi package won't install on 4.0

Michael Creel
Congratulations to the developers on the 4.0 release. This is just to note that the mpi package does not install. I am unfortunately clueless about how to solve the problem.
Reply | Threaded
Open this post in threaded view
|

Re: mpi package won't install on 4.0

tmacchant
--- michael.creel
> Congratulations to the developers on the 4.0 release. This is just to note
> that the mpi package does not install. I am unfortunately clueless about how
> to solve the problem.
>
On which platform, did you try to install mpi package? What did octave complain at installing the package?

Tatsuro


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: mpi package won't install on 4.0

jbect
In reply to this post by Michael Creel
Le 05/06/2015 12:03, Michael Creel a écrit :
> Congratulations to the developers on the 4.0 release. This is just to note
> that the mpi package does not install. I am unfortunately clueless about how
> to solve the problem.

https://savannah.gnu.org/bugs/index.php?45258


_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: mpi package won't install on 4.0

Michael Creel
Thanks, Julien. I also am using Linux (Debian), and get the same result.
Reply | Threaded
Open this post in threaded view
|

Re: mpi package won't install on 4.0

Michael Creel
Carlo, that patch solved the problem. I can't log into the bug tracker (though I have not changed my password) so I have not added a comment there. One other note, the mc_example.m in the inst directory of the mpi package does not run with Octave v4.0. If the olswrapper function is pulled out and put in a separate file, the example will run.

Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: mpi package won't install on 4.0

Carlo de Falco-2

On 6 Jun 2015, at 12:14, Michael Creel <[hidden email]> wrote:

> Carlo, that patch solved the problem.

OK, thanks for testing, so I'll apply the pacth and prepare a release.

> I can't log into the bug tracker
> (though I have not changed my password) so I have not added a comment there.

Even though you have not changed your password you may want to try "[Lost your password?]"
on the login screen to recover your account info on savannah, although unlikely, it may be
that someone guessed your password and changed it ...

> One other note, the mc_example.m in the inst directory of the mpi package
> does not run with Octave v4.0. If the olswrapper function is pulled out and
> put in a separate file, the example will run.

I'll look into this before the release but at first sight this sounds like an interpreter
bug rather than a problem with the mpi package ...

> Thanks!
c.
_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave