need installation help! (Linux)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

need installation help! (Linux)

Kendrick Smith-2

Hi all,

I can't get Octave to compile under Linux.  I have Octave v2.0.9, and
recently rebuilt my compiler using gcc v2.8.1, g77 v0.5.23, libstdc++
v2.8.1.1, and libg++ v2.8.1.1a.

When I try to build Octave, the "configure" script runs OK, but here's
what happens when I try to run "make".  First, midway through the
installation, I get many screenfuls of warnings such as:

../liboctave/MArray.h:88: warning: friend declaration `class MArray<T> pro
duct(const class MArray<T> &, const class MArray<T> &)'
../liboctave/Marray.h:88: warning:   will not be treated as a template ins
tantiation
../liboctave/MArray.h:89: warning: friend declaration `class MArray<T> quo
tient(const class MArray<T> &, const class MArray<T> &)'
../liboctave/Marray.h:89: warning:   will not be treated as a template ins
tantiation

(I'm not sure whether these warnings are relevant or not, but I'm
including them just in case!)

Then I get the error message:

file-io.cc: In function `class octave_value_list Ffopen(const class octave
_value_list &, int)':
file-io.cc:412: function `int * __errno_location()' is initialized like a
variable
make[2]: *** [file-io.o] Error 1
make[2]: Leaving directory `/usr/src/octave-2.0.9/src'
make[1]: *** [src] Error 2
make[1]: Leaving directory `/usr/src/octave-2.0.9'
make: *** [all] Error 2


Any help/insight you could give me would be most appreciated!

Thanks,
Kendrick Smith