(no subject)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

(no subject)

To: [hidden email]
Subject: trying to compile octave-1.93 on linux 2.0.27

Bug report for Octave 1.93 configured for i586-unknown-linux


When I try to compile the lates pre-2.0 version of octave on my i586
Linux 2.0.27 I it compiles smoothly until I get to readlin, at which
point the following occues:

echo making all in readline
making all in readline
cd readline ; make all
make[2]: Entering directory `/home/root/lib/octave-1.93/readline'
gcc -c  -I. -I.. -DHAVE_CONFIG_H -g -O readline.c
In file included from rldefs.h:46,
                 from readline.c:59:
/usr/include/termcap.h:39: parse error before `ospeed'
/usr/include/termcap.h:39: warning: data definition has no type or storage class
make[2]: *** [readline.o] Error 1
make[2]: Leaving directory `/home/root/lib/octave-1.93/readline'
make[1]: *** [readline] Error 2
make[1]: Leaving directory `/home/root/lib/octave-1.93'
make: *** [all] Error 2

I have tried to configure octave to run without readline to see if I
can get the rest to compile, without any success. I guess I am kind of
hoping that you will either see what's wrong (which would be quite an
achievement) or, more realistically, how to turn off the readline utility.
(I tried -disable-USE_READLINE, -disable-readline etc to no avail.)

Configuration (please do not edit this section):

uname output:     Linux demetri 2.0.27 #7 Mon Dec 2 19:38:11 EST 1996 i586
configure opts:  
Fortran compiler:
F2C:              f2c
FLIBS:            -lf2c
INCFLAGS:         -I/usr/local/include -I/usr/local/include/octave-1.93
C compiler:       gcc, version 2.7.2
CFLAGS:           -DHAVE_CONFIG_H -mieee-fp -g -O -Wall
CPICFLAG:         -fPIC
C++ compiler:     c++, version 2.7.2
CXXFLAGS:         -DHAVE_CONFIG_H  -fno-implicit-templates -mieee-fp -g -O -Wall
LDFLAGS:          -g
LIBFLAGS:         -L/usr/local/lib
RLD_FLAG:         -Xlinker -rpath -Xlinker /usr/local/lib
CXXLIBS:          -lstdc++ -lm -L/usr/lib/gcc-lib/i486-linux/2.7.2 -L/usr/i486-linux/lib -lstdc++ -lm -lgcc -lc -lgcc
TERMLIBS:         -ltermcap