octave 4.0.3 - win 10

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

octave 4.0.3 - win 10

John Donoghue-3
On my 64 bit machine using the official installer:

  PASS     13022
  FAIL         0
  XFAIL       27
  SKIPPED     54




Reply | Threaded
Open this post in threaded view
|

Re: octave 4.0.3 - win 10

tmacchant
----- Original Message -----

> From: JohnD 
> To: octave-maintainers
> Cc:
> Date: 2016/7/3, Sun 10:14
> Subject: octave 4.0.3 - win 10
>
> On my 64 bit machine using the official installer:
>
>   PASS     13022
>   FAIL         0
>   XFAIL       27
>   SKIPPED     54
>

I did not aware that.
Thanks

Is 4.0.3 the last release of 4.0.x?

Tatsuro

Reply | Threaded
Open this post in threaded view
|

Re: octave 4.0.3 - win 10

tmacchant
In reply to this post by John Donoghue-3
> From: JohnD 

> To: octave-maintainers
> Cc:
> Date: 2016/7/3, Sun 10:14
> Subject: octave 4.0.3 - win 10
>
> On my 64 bit machine using the official installer:
>
>   PASS     13022
>   FAIL         0
>   XFAIL       27
>   SKIPPED     54


I have gotten slightly different results (win 10 64bit) but 
I do not think it is serious.



  PASS     13023
  FAIL         0
  XFAIL       26
  SKIPPED     54

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: octave 4.0.3 - win 10

chechu

4.0.3 64 bit build
Debian Jessie gcc 4.9.

Only fails 2 osmesa test on make check.
Cheers,Jose

Le 3 juil. 2016 05:29, "Tatsuro MATSUOKA" <[hidden email]> a écrit :
> From: JohnD 

> To: octave-maintainers
> Cc:
> Date: 2016/7/3, Sun 10:14
> Subject: octave 4.0.3 - win 10
>
> On my 64 bit machine using the official installer:
>
>   PASS     13022
>   FAIL         0
>   XFAIL       27
>   SKIPPED     54


I have gotten slightly different results (win 10 64bit) but 
I do not think it is serious.



  PASS     13023
  FAIL         0
  XFAIL       26
  SKIPPED     54

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: octave 4.0.3 - win 10

PhilipNienhuis
In reply to this post by tmacchant
tmacchant wrote
> From: JohnD 

> To: octave-maintainers
> Cc:
> Date: 2016/7/3, Sun 10:14
> Subject: octave 4.0.3 - win 10
>
> On my 64 bit machine using the official installer:
>
>   PASS     13022
>   FAIL         0
>   XFAIL       27
>   SKIPPED     54


I have gotten slightly different results (win 10 64bit) but 
I do not think it is serious.



  PASS     13023
  FAIL         0
  XFAIL       26
  SKIPPED     54
Hmmm, with an --enable-windows-64 cross-build I get 3 FAILs on Windows 10:
- axis.m
- assert.m
(both the "usual" tolerance errors for these functions)
and
- ichol.m:
>>>>> processing C:\Programs\Octave\Octave-4.0.3_w64\share\octave\4.0.3\m\sparse\ichol.m
***** error <pivot equal to 0> ichol (sparse (-0))
!!!!! error failed.
Expected <pivot equal to 0>, but got no error


Philip
Reply | Threaded
Open this post in threaded view
|

Re: octave 4.0.3 - win 10

tmacchant
----- Original Message -----

> From: PhilipNienhuis
> To: octave-maintainers
> Cc:
> Date: 2016/7/3, Sun 19:38
> Subject: Re: octave 4.0.3 - win 10
>
>t macchant wrote
>>>  From: JohnD 
>>
>>>  To: octave-maintainers
>>>  Cc:
>>>  Date: 2016/7/3, Sun 10:14
>>>  Subject: octave 4.0.3 - win 10
>>>
>>>  On my 64 bit machine using the official installer:
>>>
>>>    PASS     13022
>>>    FAIL         0
>>>    XFAIL       27
>>>    SKIPPED     54
>>
>>
>>  I have gotten slightly different results (win 10 64bit) but 
>>  I do not think it is serious.
>>
>>
>>
>>    PASS     13023
>>    FAIL         0
>>    XFAIL       26
>>    SKIPPED     54
>
> Hmmm, with an --enable-windows-64 cross-build I get 3 FAILs on Windows 10:
> - axis.m
> - assert.m
> (both the "usual" tolerance errors for these functions)
> and
> - ichol.m:
>>>>>>  processing
>>>>>>
> C:\Programs\Octave\Octave-4.0.3_w64\share\octave\4.0.3\m\sparse\ichol.m
> ***** error <pivot equal to 0> ichol (sparse (-0))
> !!!!! error failed.
> Expected <pivot equal to 0>, but got no error
>
>
> Philip


With --enable-windows-64 cross-build I get 2 FAILs on Windows 10


  PASS     13021
  FAIL         2
  XFAIL       26
  SKIPPED     54

For axis.m and assert.m, perhaps the same tolerance errors occured as those by Philip.
 

>>>>> processing C:\octave\Octave-4.0.3-x64\share\octave\4.0.3\m\plot\appearance\axis.m

***** test
 hf = figure ("visible", "off");
 unwind_protect
   a = logspace (-5, 1, 10);
   loglog (a, -a);
   axis tight;
   assert (axis (), [1e-5, 10, -10, -1e-5]);
 unwind_protect_cleanup
   close (hf);
 end_unwind_protect
!!!!! test failed
ASSERT errors for:  assert (axis (),[1e-5, 10, -10, -1e-5])

  Location  |  Observed  |  Expected  |  Reason
    (1)         1e-005       1e-005      Abs err 5.0822e-021 exceeds tol 0
    (4)        -1e-005      -1e-005      Abs err 5.0822e-021 exceeds tol 0

>>>>> processing C:\octave\Octave-4.0.3-x64\share\octave\4.0.3\m\testfun\assert.m
***** test
 x = [-40:0];
 y1 = (10.^x).*(10.^x);
 y2 = 10.^(2*x);
 assert (y1, y2, eps (y1));
 fail ("assert (y1, y2 + eps*1e-70, eps (y1))");
!!!!! test failed
ASSERT errors for:  assert (y1,y2,eps (y1))

  Location  |  Observed  |  Expected  |  Reason
    (11)        1e-060       1e-060      Abs err 4.1454e-076 exceeds tol 1.3818e-076
    (13)        1e-056       1e-056      Abs err 3.3959e-072 exceeds tol 1.132e-072
    (14)        1e-054       1e-054      Abs err 4.3467e-070 exceeds tol 1.4489e-070
    (19)        1e-044       1e-044      Abs err 3.7338e-060 exceeds tol 1.2446e-060
    (22)        1e-038       1e-038      Abs err 2.6101e-054 exceeds tol 1.3051e-054
    (23)        1e-036       1e-036      Abs err 3.341e-052 exceeds tol 1.6705e-052
    (27)        1e-028       1e-028      Abs err 2.2421e-044 exceeds tol 1.121e-044
    (29)        1e-024       1e-024      Abs err 3.6734e-040 exceeds tol 1.8367e-040

I do not see FAIL on ichol.m.

Tatsuro


Reply | Threaded
Open this post in threaded view
|

Re: octave 4.0.3 - win 10

tmacchant
----- Original Message -----

> From: Tatsuro MATSUOKA 
> To: PhilipNienhuis ; "octave-maintainers
> Cc:
> Date: 2016/7/4, Mon 08:54
> Subject: Re: octave 4.0.3 - win 10
>
> ----- Original Message -----
>
>>  From: PhilipNienhuis
>>  To: octave-maintainers
>>  Cc:
>>  Date: 2016/7/3, Sun 19:38
>>  Subject: Re: octave 4.0.3 - win 10
>>
>> t macchant wrote
>>>>   From: JohnD 
>>>
>>>>   To: octave-maintainers
>>>>   Cc:
>>>>   Date: 2016/7/3, Sun 10:14
>>>>   Subject: octave 4.0.3 - win 10
>>>>
>>>>   On my 64 bit machine using the official installer:
>>>>
>>>>     PASS     13022
>>>>     FAIL         0
>>>>     XFAIL       27
>>>>     SKIPPED     54
>>>
>>>
>>>   I have gotten slightly different results (win 10 64bit) but 
>>>   I do not think it is serious.
>>>
>>>
>>>
>>>     PASS     13023
>>>     FAIL         0
>>>     XFAIL       26
>>>     SKIPPED     54
>>
>>  Hmmm, with an --enable-windows-64 cross-build I get 3 FAILs on Windows 10:
>>  - axis.m
>>  - assert.m
>>  (both the "usual" tolerance errors for these functions)
>>  and
>>  - ichol.m:
>>>>>>>   processing
>>>>>>>
>>
> C:\Programs\Octave\Octave-4.0.3_w64\share\octave\4.0.3\m\sparse\ichol.m
>>  ***** error <pivot equal to 0> ichol (sparse (-0))
>>  !!!!! error failed.
>>  Expected <pivot equal to 0>, but got no error
>>
>>
>>  Philip
>
>
> With --enable-windows-64 cross-build I get 2 FAILs on Windows 10
>
>
>   PASS     13021
>   FAIL         2
>   XFAIL       26
>   SKIPPED     54
>
> For axis.m and assert.m, perhaps the same tolerance errors occured as those by
> Philip.
>  
>
>>>>>>  processing
> C:\octave\Octave-4.0.3-x64\share\octave\4.0.3\m\plot\appearance\axis.m
>
> ***** test
>  hf = figure ("visible", "off");
>  unwind_protect
>    a = logspace (-5, 1, 10);
>    loglog (a, -a);
>    axis tight;
>    assert (axis (), [1e-5, 10, -10, -1e-5]);
>  unwind_protect_cleanup
>    close (hf);
>  end_unwind_protect
> !!!!! test failed
> ASSERT errors for:  assert (axis (),[1e-5, 10, -10, -1e-5])
>
>   Location  |  Observed  |  Expected  |  Reason
>     (1)         1e-005       1e-005      Abs err 5.0822e-021 exceeds tol 0
>     (4)        -1e-005      -1e-005      Abs err 5.0822e-021 exceeds tol 0
>
>>>>>>  processing
> C:\octave\Octave-4.0.3-x64\share\octave\4.0.3\m\testfun\assert.m
> ***** test
>  x = [-40:0];
>  y1 = (10.^x).*(10.^x);
>  y2 = 10.^(2*x);
>  assert (y1, y2, eps (y1));
>  fail ("assert (y1, y2 + eps*1e-70, eps (y1))");
> !!!!! test failed
> ASSERT errors for:  assert (y1,y2,eps (y1))
>
>   Location  |  Observed  |  Expected  |  Reason
>     (11)        1e-060       1e-060      Abs err 4.1454e-076 exceeds tol
> 1.3818e-076
>     (13)        1e-056       1e-056      Abs err 3.3959e-072 exceeds tol
> 1.132e-072
>     (14)        1e-054       1e-054      Abs err 4.3467e-070 exceeds tol
> 1.4489e-070
>     (19)        1e-044       1e-044      Abs err 3.7338e-060 exceeds tol
> 1.2446e-060
>     (22)        1e-038       1e-038      Abs err 2.6101e-054 exceeds tol
> 1.3051e-054
>     (23)        1e-036       1e-036      Abs err 3.341e-052 exceeds tol
> 1.6705e-052
>     (27)        1e-028       1e-028      Abs err 2.2421e-044 exceeds tol
> 1.121e-044
>     (29)        1e-024       1e-024      Abs err 3.6734e-040 exceeds tol
> 1.8367e-040
>
> I do not see FAIL on ichol.m.
>
> Tatsuro


Also I executed a test with --enable-windows-64 --enable-64.
The results are the same as those with --enable-windows-64 as expected.

Tatsuro