parallel for

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

parallel for

amin izadi
Hi
I have Octave 5.1.0 and I want to install parallel package on my ubuntu 64 bit. But after using " pkg install -forge parallel", this error appears: " parallel needs struct >= 1.0.12".
please help me and tell me how to fix the problem. Is the any straight "parfor" like Matlab in octave?
thanks in advance


Reply | Threaded
Open this post in threaded view
|

Re: parallel for

siko1056
On 9/3/20 8:32 AM, amin izadi wrote:
> Hi
> I have Octave 5.1.0 and I want to install parallel package on my ubuntu
> 64 bit. But after using " pkg install -forge parallel", this error
> appears: " parallel needs struct >= 1.0.12".
> please help me and tell me how to fix the problem. Is the any
> straight "parfor" like Matlab in octave?
> thanks in advance
>


Unlike in Ubuntu, the "pkg" package manager of Octave is not (yet) able
to resolve dependencies on its own.  Just install the dependency first:

   pkg install -forge struct
   pkg install -forge parallel

Sorry for the inconvenience.

HTH,
Kai


Reply | Threaded
Open this post in threaded view
|

Re: parallel for

Octave - General mailing list


Kai Torben Ohlhus <[hidden email]> (Wed, 2 Sep 2020 09:36:36 +0900) wrote:

> On 9/3/20 8:32 AM, amin izadi wrote:
>> Hi
>> I have Octave 5.1.0 and I want to install parallel package on my ubuntu
>> 64 bit. But after using " pkg install -forge parallel", this error
>> appears: " parallel needs struct >= 1.0.12".
>> please help me and tell me how to fix the problem. Is the any
>> straight "parfor" like Matlab in octave?
>> thanks in advance
>>
>
>
> Unlike in Ubuntu, the "pkg" package manager of Octave is not (yet) able
> to resolve dependencies on its own.  Just install the dependency first:
>
>    pkg install -forge struct
>    pkg install -forge parallel
>
> Sorry for the inconvenience.
>
> HTH,
> Kai
>

  Thanks for catching this, Kai.
  Etienne


--
http://www.egdn.net/etienne.html



----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.