pkg install -forge broke after update

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

pkg install -forge broke after update

Thomas D. Dean-2
I updated to latest hg sources, configure, make, make check, make
install.  Some warnings, no errors.

octave:1> [v,d]=version()
v = 6.0.90
d = 2020-08-26
octave:2> pkg install -forge control
error: unpack: unarchiving program exited with status: 2

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
error: called from
     unpack at line 279 column 5
     untar at line 48 column 5
     install at line 93 column 9
     pkg at line 566 column 9

Tom Dean


Reply | Threaded
Open this post in threaded view
|

Re: pkg install -forge broke after update

Dmitri A. Sergatskov
sourseforge appears to be done. The "tar.gz" file is a an html file that says:
<html><head>
<title>SourceForge</title>
<!-- <script src="/js/jquery.com/jquery-1.11.0.min.js"></script> -->
<script src="https://code.jquery.com/jquery-1.11.0.min.js"></script>
<script src="https://sourceforge.net/js/mirrors.js"></script>
<script src="/js/sf.js"></script>
<script>
var DR_loc = DR_parse_hash_url();
if (DR_loc) {
    DR_sf_main(DR_loc);
} else {
    window.location.href = 'https://sourceforge.net/home.html';
}
</script>
<meta name="description" content="Free, secure and fast downloads from the largest Open Source applications and software directory - SourceForge.net"/>
</head><body>
<noscript>
We're sorry -- the Sourceforge site is currently in Disaster Recovery mode.  Please check back later.
</noscript>
</body></html>

On Mon, Aug 31, 2020 at 11:59 PM Thomas D. Dean <[hidden email]> wrote:
I updated to latest hg sources, configure, make, make check, make
install.  Some warnings, no errors.

octave:1> [v,d]=version()
v = 6.0.90
d = 2020-08-26
octave:2> pkg install -forge control
error: unpack: unarchiving program exited with status: 2

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
error: called from
     unpack at line 279 column 5
     untar at line 48 column 5
     install at line 93 column 9
     pkg at line 566 column 9

Tom Dean




Reply | Threaded
Open this post in threaded view
|

Re: pkg install -forge broke after update

Dmitri A. Sergatskov

On Tue, Sep 1, 2020 at 12:02 AM Dmitri A. Sergatskov <[hidden email]> wrote:
sourseforge appears to be done. The "tar.gz" file is a an html file that says:
<html><head>
<title>SourceForge</title>
<!-- <script src="/js/jquery.com/jquery-1.11.0.min.js"></script> -->
<script src="https://code.jquery.com/jquery-1.11.0.min.js"></script>
<script src="https://sourceforge.net/js/mirrors.js"></script>
<script src="/js/sf.js"></script>
<script>
var DR_loc = DR_parse_hash_url();
if (DR_loc) {
    DR_sf_main(DR_loc);
} else {
    window.location.href = 'https://sourceforge.net/home.html';
}
</script>
<meta name="description" content="Free, secure and fast downloads from the largest Open Source applications and software directory - SourceForge.net"/>
</head><body>
<noscript>
We're sorry -- the Sourceforge site is currently in Disaster Recovery mode.  Please check back later.
</noscript>
</body></html>

On Mon, Aug 31, 2020 at 11:59 PM Thomas D. Dean <[hidden email]> wrote:
I updated to latest hg sources, configure, make, make check, make
install.  Some warnings, no errors.

octave:1> [v,d]=version()
v = 6.0.90
d = 2020-08-26
octave:2> pkg install -forge control
error: unpack: unarchiving program exited with status: 2

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
error: called from
     unpack at line 279 column 5
     untar at line 48 column 5
     install at line 93 column 9
     pkg at line 566 column 9

Tom Dean




Reply | Threaded
Open this post in threaded view
|

Re: pkg install -forge broke after update

Thomas D. Dean-2
In reply to this post by Thomas D. Dean-2
On 2020-08-31 20:58, Thomas D. Dean wrote:

> I updated to latest hg sources, configure, make, make check, make
> install.  Some warnings, no errors.
>
> octave:1> [v,d]=version()
> v = 6.0.90
> d = 2020-08-26
> octave:2> pkg install -forge control
> error: unpack: unarchiving program exited with status: 2
>
> gzip: stdin: not in gzip format
> tar: Child returned status 1
> tar: Error is not recoverable: exiting now
> error: called from
>      unpack at line 279 column 5
>      untar at line 48 column 5
>      install at line 93 column 9
>      pkg at line 566 column 9
>
> Tom Dean
>
>

Now, it works!
I exited octave and restarted.

octave:13> pkg install -forge control
A couple of compile warnings about array index, but, success.

And, now, I have 12 failed tests! (119 in my earlier email)

octave:14> pkg test control
...
/home/tomdean/octave/control-3.2.0/ltimodels.m ...... pass   35/47
                                                       FAIL   12

Code rot?

Tom Dean


Reply | Threaded
Open this post in threaded view
|

Re: pkg install -forge broke after update

Thomas D. Dean-2
On 2020-08-31 21:19, Thomas D. Dean wrote:

> On 2020-08-31 20:58, Thomas D. Dean wrote:
>> I updated to latest hg sources, configure, make, make check, make
>> install.  Some warnings, no errors.
>>
>> octave:1> [v,d]=version()
>> v = 6.0.90
>> d = 2020-08-26
>> octave:2> pkg install -forge control
>> error: unpack: unarchiving program exited with status: 2
>>
>> gzip: stdin: not in gzip format
>> tar: Child returned status 1
>> tar: Error is not recoverable: exiting now
>> error: called from
>>      unpack at line 279 column 5
>>      untar at line 48 column 5
>>      install at line 93 column 9
>>      pkg at line 566 column 9
>>
>> Tom Dean
>>
>>
>
> Now, it works!
> I exited octave and restarted.
>
> octave:13> pkg install -forge control
> A couple of compile warnings about array index, but, success.
>
> And, now, I have 12 failed tests! (119 in my earlier email)
>
> octave:14> pkg test control
> ...
> /home/tomdean/octave/control-3.2.0/ltimodels.m ...... pass   35/47
>                                                        FAIL   12
>
> Code rot?
>
> Tom Dean
>
>

I can not repeat the previous failures.

I redid everything.

rm the octave build directory
$ ../configure LDFLAGS=-L/usr/local/lib/OpenBlas/lib \
--enable-threads=posix CPPFLAGS=-I/usr/include/suitesparse

build and install octave
pkg install -forge control
   A few warnings
pkg test control.
   12 errors, all in ltimodels

Weird.

Maybe something not cleaned out in the build directory???

Internet error?

Tom Dean