pkg install from gui-octave 4.4.1 also not working

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

pkg install from gui-octave 4.4.1 also not working

dan nessett-2
I am beginning to regret installing gui-octave 4.4.1. While waiting for a resolution to the plot file type problem, I thought I would install some of the packages I had installed on gui-octave 4.0.3. I began by attempting to install signal, which has a dependency on the control package. (I will state again that I installed gui-octave from the dmg available at Octave.app Downloads and that I am running High Sierra (10.13.6). This generated the following error:


>> pkg install -forge control
<built-in>: internal compiler error: Illegal instruction: 4
libbacktrace could not find executable to open
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://github.com/Homebrew/homebrew-core/issues> for instructions.
make: *** [slicotlibrary.a] Error 1
make: *** Waiting for unfinished jobs....
tar -xzf slicot.tar.gz
/Applications/Octave-4.4.1.app/Contents/Resources/usr/Cellar/octave-octave-app_4.4.1_0/4.4.1/bin/mkoctfile-4.4.1 -Wall -Wno-deprecated-declarations  __control_helper_functions__.cc
mkdir sltmp
mv slicot/src/*.f ./sltmp
mv slicot/src_aux/*.f ./sltmp
cp TG04BX.fortran ./sltmp/TG04BX.f
cp TB01ZD.fortran ./sltmp/TB01ZD.f
cd sltmp; /Applications/Octave-4.4.1.app/Contents/Resources/usr/Cellar/octave-octave-app_4.4.1_0/4.4.1/bin/mkoctfile-4.4.1 -c *.f

pkg: error running `make' for the control package.
error: called from
    configure_make at line 99 column 9
    install at line 184 column 7
    pkg at line 437 column 9