pkg install not working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pkg install not working

kpartha
Hi,
     I am unable to install Octave packages in Ubuntu OS. The 'pkg install
-verbose io' terminates with " make: not found" error.
__________________________________
uname -a
Linux User 4.18.0-21-generic #22~18.04.1-Ubuntu SMP Thu May 16 15:07:19 UTC
2019 x86_64 x86_64 x86_64 GNU/Linux
-------------------------------
pkg install -forge io
sh: 1: make: not found

pkg: error running `make' for the io package.
error: called from
    configure_make at line 95 column 9
    install at line 194 column 7
    pkg at line 394 column 9
--------------------------------------------------
pkg install -forge image
sh: 1: make: not found

pkg: error running `make' for the image package.
error: called from
    configure_make at line 95 column 9
    install at line 194 column 7
    pkg at line 394 column 9
--------------------------------------------
parthasarathy@Lab6-Parthasarathy:~/.config/octave$ uname -a
Linux Lab6-Parthasarathy 4.18.0-21-generic #22~18.04.1-Ubuntu SMP Thu May 16
15:07:19 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Any suggestions on how to fix this?
Thanks in advance.

-Kp



--
Sent from: https://octave.1599824.n4.nabble.com/Octave-General-f1599825.html


Reply | Threaded
Open this post in threaded view
|

Re: pkg install not working

siko1056
On 8/10/19 8:36 PM, kpartha wrote:

> Hi,
>      I am unable to install Octave packages in Ubuntu OS. The 'pkg install
> -verbose io' terminates with " make: not found" error.
> __________________________________
> uname -a
> Linux User 4.18.0-21-generic #22~18.04.1-Ubuntu SMP Thu May 16 15:07:19 UTC
> 2019 x86_64 x86_64 x86_64 GNU/Linux
> -------------------------------
> pkg install -forge io
> sh: 1: make: not found
>
> pkg: error running `make' for the io package.
> error: called from
>     configure_make at line 95 column 9
>     install at line 194 column 7
>     pkg at line 394 column 9
> --------------------------------------------------
> pkg install -forge image
> sh: 1: make: not found
>
> pkg: error running `make' for the image package.
> error: called from
>     configure_make at line 95 column 9
>     install at line 194 column 7
>     pkg at line 394 column 9
> --------------------------------------------
> parthasarathy@Lab6-Parthasarathy:~/.config/octave$ uname -a
> Linux Lab6-Parthasarathy 4.18.0-21-generic #22~18.04.1-Ubuntu SMP Thu May 16
> 15:07:19 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
>
> Any suggestions on how to fix this?
> Thanks in advance.
>
> -Kp
>

Installing GNU Make and other build tools should fix your problem.  See

   https://help.ubuntu.com/community/InstallingCompilers

HTH,

Kai