plot window hangs

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

plot window hangs

David Parman
I have been having trouble with the plot window hanging in Windows XP. I am running Octave 3.2.3 for XP. Typically, the first plot opens Ok but then usually hangs after the 2nd plot. It also hangs if I try to print the plot. If I force the plot window closed, the Octave command window will hang if I then try to plot again. Is there a fix for this?

--

"The cost of a thing is the amount of life which is required to be exchanged for it" -- Thoreau


_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

Benjamin Lindner
David Parman wrote:
> I have been having trouble with the plot window hanging in Windows XP. I
> am running Octave 3.2.3 for XP. Typically, the first plot opens Ok but
> then usually hangs after the 2nd plot. It also hangs if I try to print
> the plot. If I force the plot window closed, the Octave command window
> will hang if I then try to plot again. Is there a fix for this?

Can you post an example script demonstrating the problem?
I don't see this using 3.2.3.
If you try 3.2.4, does the problem still persist?

benjamin

_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
nob
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

nob
I also have same problem on Octave 3.2.4 for XP. It happens always for wxt and windows terminal.
The details in case of wxt terminal are as follows;
1. Type "plot(1:10)" on Octave.
2. Plot window is popped up, however no buttons are appeared on the window.
3. The window couldn't be moved for a several seconds.
4. After a several seconds, the window can be moved. However, the contents of the window is wiped out and nothing is displayed.
5. All of built-in command of gnuplot can't be used. No response. Hanged up.
6. Type "plot(1:10)" on Octave again, the plot appears correctly.
7. However, once type the built-in command on plot window (ex. "m" or "e"), no response. Then gnuplot  window is hanged up.

- I have applied the patch for some issues ("oct2mat" and "ginput.m" problem)
- I have already confirmed that the "gnuplot.exe" in the Octave\bin directory can worked correctly when it is run individualy.
- At first, this problem was found on my office PC. However, same phenomena was happened on my private PC. My office one is Dell, and private one is ThinkPad.
- On Octave-3.1.5, same phenomena happen. On Octave-3.0.3, no problem found.

Please give me any idea to avoid this problem...
If you need more information, please let me know.

Regards,
Nobuhiko Wasa

nob
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

nob
As a result of some experiments, I think this problem comes from the
command of gnuplot and its timing on plot window.
I did the following script.
plot(1:10);pause(5);plot(1:10);

When one of plot window command ("m" or "e") is issued during pause,
hang-up does not happen.
When no plot window command is issued during pause, then the plot
window command is issued after the end of 2nd plot(1:10) command,
hang-up happens.

However, this workaround is very inconvenience...


2010/7/2 nob <[hidden email]>:

>
> I also have same problem on Octave 3.2.4 for XP. It happens always for wxt
> and windows terminal.
> The details in case of wxt terminal are as follows;
> 1. Type "plot(1:10)" on Octave.
> 2. Plot window is popped up, however no buttons are appeared on the window.
> 3. The window couldn't be moved for a several seconds.
> 4. After a several seconds, the window can be moved. However, the contents
> of the window is wiped out and nothing is displayed.
> 5. All of built-in command of gnuplot can't be used. No response. Hanged up.
> 6. Type "plot(1:10)" on Octave again, the plot appears correctly.
> 7. However, once type the built-in command on plot window (ex. "m" or "e"),
> no response. Then gnuplot  window is hanged up.
>
> - I have applied the patch for some issues ("oct2mat" and "ginput.m"
> problem)
> - I have already confirmed that the "gnuplot.exe" in the Octave\bin
> directory can worked correctly when it is run individualy.
> - At first, this problem was found on my office PC. However, same phenomena
> was happened on my private PC. My office one is Dell, and private one is
> ThinkPad.
> - On Octave-3.1.5, same phenomena happen. On Octave-3.0.3, no problem found.
>
> Please give me any idea to avoid this problem...
> If you need more information, please let me know.
>
> Regards,
> Nobuhiko Wasa
>
>
> --
> View this message in context: http://octave.1599824.n4.nabble.com/plot-window-hangs-tp1681494p2275912.html
> Sent from the Octave - General mailing list archive at Nabble.com.
> _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
>



--
Sincerely,
N. Wasa

_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

Jmarc B.
The attached message provides a solution which works... This is the
consequence of an apparently famous bug in Octave.

Jean-Marc BOUSSARD




Nobuhiko WASA a écrit :

> As a result of some experiments, I think this problem comes from the
> command of gnuplot and its timing on plot window.
> I did the following script.
> plot(1:10);pause(5);plot(1:10);
>
> When one of plot window command ("m" or "e") is issued during pause,
> hang-up does not happen.
> When no plot window command is issued during pause, then the plot
> window command is issued after the end of 2nd plot(1:10) command,
> hang-up happens.
>
> However, this workaround is very inconvenience...
>
>
> 2010/7/2 nob <[hidden email]>:
>  
>> I also have same problem on Octave 3.2.4 for XP. It happens always for wxt
>> and windows terminal.
>> The details in case of wxt terminal are as follows;
>> 1. Type "plot(1:10)" on Octave.
>> 2. Plot window is popped up, however no buttons are appeared on the window.
>> 3. The window couldn't be moved for a several seconds.
>> 4. After a several seconds, the window can be moved. However, the contents
>> of the window is wiped out and nothing is displayed.
>> 5. All of built-in command of gnuplot can't be used. No response. Hanged up.
>> 6. Type "plot(1:10)" on Octave again, the plot appears correctly.
>> 7. However, once type the built-in command on plot window (ex. "m" or "e"),
>> no response. Then gnuplot  window is hanged up.
>>
>> - I have applied the patch for some issues ("oct2mat" and "ginput.m"
>> problem)
>> - I have already confirmed that the "gnuplot.exe" in the Octave\bin
>> directory can worked correctly when it is run individualy.
>> - At first, this problem was found on my office PC. However, same phenomena
>> was happened on my private PC. My office one is Dell, and private one is
>> ThinkPad.
>> - On Octave-3.1.5, same phenomena happen. On Octave-3.0.3, no problem found.
>>
>> Please give me any idea to avoid this problem...
>> If you need more information, please let me know.
>>
>> Regards,
>> Nobuhiko Wasa
>>
>>
>> --
>> View this message in context: http://octave.1599824.n4.nabble.com/plot-window-hangs-tp1681494p2275912.html
>> Sent from the Octave - General mailing list archive at Nabble.com.
>> _______________________________________________
>> Help-octave mailing list
>> [hidden email]
>> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
>>
>>    
>
>
>
>  

What you met might be the notorious oct2mat issue.
Please see the below

http://wiki.octave.org/wiki.pl?OctaveForWindows
1. Standalone ports
 1.1. Octave 3.2.4 for Windows MinGW32
 Additional important topics found after the release:

[I should acknowledge that this reply is a copy-paste of a previous list email].

On Sun, Jun 20, 2010 at 6:28 PM, Jmarc B. <[hidden email]> wrote:
I have just the same error with Window7 : the function PLOT works well, but do not produce any new window, as indicated on screen image 1 : . Then, I issue a PRINT command : the graphic windows opens... and freeze (with the "not responding" message from Windows : see image 2 below).. The file with the z.png is correctly created in response to PRINT (Z.PNG'). GNUPLOT works perfectly, executing demos... (the demos are coming from the distribution, but I use the GNUPLOT.EXE in the OCTAVE directory) Any solution ?

View this message in context: Re: Plot window freezes
Sent from the Octave - General mailing list archive at Nabble.com.

_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave




--
/* andy buckle */


---------------------------------------------------------------------------------------------------
Texte inséré par Panda IS 2010:

S'il s'agit d'un mail indésirable (SPAM), cliquez sur le lien suivant pour le reclasser : <a href="http://localhost:6083/Panda?ID=pav_262&SPAM=true&path=C:\Users\Jean-Marc\AppData\Local\Panda Security\Panda Internet Security 2010\AntiSpam">C'est du SPAM !
---------------------------------------------------------------------------------------------------

_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
nob
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

nob
I have already applied this oct2mat patch just after install. Also, renaming the older ginput.m file patch has been applied. However the problem is still coming in.

After many trials, I got workaround.
I have added "ginput(gcf());" at then end of "__plt__.m" file. Then the hang-up problem now disappear. However, some action (hit key or mouse button) is required on plot window just after plotting to make the prompt of Octave window come back.

I'm not sure whether this action is appropriate method or not...


2010/7/2 Jean-Marc Boussard <[hidden email]>
The attached message provides a solution which works... This is the consequence of an apparently famous bug in Octave.

Jean-Marc BOUSSARD




Nobuhiko WASA a écrit :

As a result of some experiments, I think this problem comes from the
command of gnuplot and its timing on plot window.
I did the following script.
plot(1:10);pause(5);plot(1:10);

When one of plot window command ("m" or "e") is issued during pause,
hang-up does not happen.
When no plot window command is issued during pause, then the plot
window command is issued after the end of 2nd plot(1:10) command,
hang-up happens.

However, this workaround is very inconvenience...


2010/7/2 nob <[hidden email]>:
 
I also have same problem on Octave 3.2.4 for XP. It happens always for wxt
and windows terminal.
The details in case of wxt terminal are as follows;
1. Type "plot(1:10)" on Octave.
2. Plot window is popped up, however no buttons are appeared on the window.
3. The window couldn't be moved for a several seconds.
4. After a several seconds, the window can be moved. However, the contents
of the window is wiped out and nothing is displayed.
5. All of built-in command of gnuplot can't be used. No response. Hanged up.
6. Type "plot(1:10)" on Octave again, the plot appears correctly.
7. However, once type the built-in command on plot window (ex. "m" or "e"),
no response. Then gnuplot  window is hanged up.

- I have applied the patch for some issues ("oct2mat" and "ginput.m"
problem)
- I have already confirmed that the "gnuplot.exe" in the Octave\bin
directory can worked correctly when it is run individualy.
- At first, this problem was found on my office PC. However, same phenomena
was happened on my private PC. My office one is Dell, and private one is
ThinkPad.
- On Octave-3.1.5, same phenomena happen. On Octave-3.0.3, no problem found.

Please give me any idea to avoid this problem...
If you need more information, please let me know.

Regards,
Nobuhiko Wasa


--
View this message in context: http://octave.1599824.n4.nabble.com/plot-window-hangs-tp1681494p2275912.html
Sent from the Octave - General mailing list archive at Nabble.com.
_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave

   



 

What you met might be the notorious oct2mat issue.
Please see the below

http://wiki.octave.org/wiki.pl?OctaveForWindows
1. Standalone ports
 1.1. Octave 3.2.4 for Windows MinGW32
 Additional important topics found after the release:

[I should acknowledge that this reply is a copy-paste of a previous list email].

On Sun, Jun 20, 2010 at 6:28 PM, Jmarc B. <[hidden email]> wrote:
I have just the same error with Window7 : the function PLOT works well, but do not produce any new window, as indicated on screen image 1 : . Then, I issue a PRINT command : the graphic windows opens... and freeze (with the "not responding" message from Windows : see image 2 below).. The file with the z.png is correctly created in response to PRINT (Z.PNG'). GNUPLOT works perfectly, executing demos... (the demos are coming from the distribution, but I use the GNUPLOT.EXE in the OCTAVE directory) Any solution ?

View this message in context: Re: Plot window freezes
Sent from the Octave - General mailing list archive at Nabble.com.

_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave




--
/* andy buckle */


---------------------------------------------------------------------------------------------------
Texte inséré par Panda IS 2010:

S'il s'agit d'un mail indésirable (SPAM), cliquez sur le lien suivant pour le reclasser : C'est du SPAM !
---------------------------------------------------------------------------------------------------



--
Sincerely,
N. Wasa


_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

tmacchant
Hello

Hmmmm! You have applied the fixes for the oct2mat and the ginput issue.

Unfortunately I cannot reproduce the issue that you have met.  I have been using the windows XP, which
you have used.  I have installed octave-3.2.4/mingw32 at least four win XP machine.  After application
of the fixes for the oct2mat and the ginput to the octave installed, plot problem that you have
mentioned have not occurred.

Please try uninstall and reinstall the octave. Sometimes this foolish treatment solves the problem on
windows if you have not tried it yet.

Sorry I cannot give you useful help.

Regards

Tatsuro  

--- Nobuhiko WASA wrote:

> I have already applied this oct2mat patch just after install. Also, renaming
> the older ginput.m file patch has been applied. However the problem is still
> coming in.
>
> After many trials, I got workaround.
> I have added "ginput(gcf());" at then end of "__plt__.m" file. Then the
> hang-up problem now disappear. However, some action (hit key or mouse
> button) is required on plot window just after plotting to make the prompt of
> Octave window come back.
>
> I'm not sure whether this action is appropriate method or not...
>
>
> 2010/7/2 Jean-Marc Boussard <[hidden email]>
>
> > The attached message provides a solution which works... This is the
> > consequence of an apparently famous bug in Octave.
> >
> > Jean-Marc BOUSSARD
> >
> >
> >
> >
> > Nobuhiko WASA a 将アcrit :
> >
> >  As a result of some experiments, I think this problem comes from the
> >> command of gnuplot and its timing on plot window.
> >> I did the following script.
> >> plot(1:10);pause(5);plot(1:10);
> >>
> >> When one of plot window command ("m" or "e") is issued during pause,
> >> hang-up does not happen.
> >> When no plot window command is issued during pause, then the plot
> >> window command is issued after the end of 2nd plot(1:10) command,
> >> hang-up happens.
> >>
> >> However, this workaround is very inconvenience...
> >>
> >>
> >> 2010/7/2 nob <[hidden email]>:
> >>
> >>
> >>> I also have same problem on Octave 3.2.4 for XP. It happens always for
> >>> wxt
> >>> and windows terminal.
> >>> The details in case of wxt terminal are as follows;
> >>> 1. Type "plot(1:10)" on Octave.
> >>> 2. Plot window is popped up, however no buttons are appeared on the
> >>> window.
> >>> 3. The window couldn't be moved for a several seconds.
> >>> 4. After a several seconds, the window can be moved. However, the
> >>> contents
> >>> of the window is wiped out and nothing is displayed.
> >>> 5. All of built-in command of gnuplot can't be used. No response. Hanged
> >>> up.
> >>> 6. Type "plot(1:10)" on Octave again, the plot appears correctly.
> >>> 7. However, once type the built-in command on plot window (ex. "m" or
> >>> "e"),
> >>> no response. Then gnuplot  window is hanged up.
> >>>
> >>> - I have applied the patch for some issues ("oct2mat" and "ginput.m"
> >>> problem)
> >>> - I have already confirmed that the "gnuplot.exe" in the Octave\bin
> >>> directory can worked correctly when it is run individualy.
> >>> - At first, this problem was found on my office PC. However, same
> >>> phenomena
> >>> was happened on my private PC. My office one is Dell, and private one is
> >>> ThinkPad.
> >>> - On Octave-3.1.5, same phenomena happen. On Octave-3.0.3, no problem
> >>> found.
> >>>
> >>> Please give me any idea to avoid this problem...
> >>> If you need more information, please let me know.
> >>>
> >>> Regards,
> >>> Nobuhiko Wasa
> >>>
> >>>
> >>> --
> >>> View this message in context:
> >>> http://octave.1599824.n4.nabble.com/plot-window-hangs-tp1681494p2275912.html
> >>> Sent from the Octave - General mailing list archive at Nabble.com.
> >>> _______________________________________________
> >>> Help-octave mailing list
> >>> [hidden email]
> >>> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
> >>>
> >>>
> >>>
> >>
> >>
> >>
> >>
> >>
> >
> > What you met might be the notorious oct2mat issue.
> > Please see the below
> >
> > http://wiki.octave.org/wiki.pl?OctaveForWindows
> > 1. Standalone ports
> >  1.1. Octave 3.2.4 for Windows MinGW32
> >  Additional important topics found after the release:
> >
> > [I should acknowledge that this reply is a copy-paste of a previous list
> > email].
> >
> > On Sun, Jun 20, 2010 at 6:28 PM, Jmarc B. <[hidden email]>wrote:
> >
> >> I have just the same error with Window7 : the function PLOT works well,
> >> but do not produce any new window, as indicated on screen image 1 : . Then,
> >> I issue a PRINT command : the graphic windows opens... and freeze (with the
> >> "not responding" message from Windows : see image 2 below).. The file with
> >> the z.png is correctly created in response to PRINT (Z.PNG'). GNUPLOT
> >> works perfectly, executing demos... (the demos are coming from the
> >> distribution, but I use the GNUPLOT.EXE in the OCTAVE directory) Any
> >> solution ?
> >> ------------------------------
> >> View this message in context: Re: Plot window
> freezes<http://octave.1599824.n4.nabble.com/Plot-window-freezes-tp1638002p2261807.html>
> >> Sent from the Octave - General mailing list
> archive<http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html>at Nabble.com.
> >>
> >> _______________________________________________
> >> Help-octave mailing list
> >> [hidden email]
> >> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
> >>
> >>
> >
> >
> > --
> > /* andy buckle */
> >
> >
> >
> >
> ---------------------------------------------------------------------------------------------------
> > *Texte ins将アr将ア par Panda IS 2010:*
> >
> > S'il s'agit d'un mail ind将アsirable (SPAM), cliquez sur le lien suivant pour
> > le reclasser : C'est du SPAM
>
!<http://localhost:6083/Panda?ID=pav_262&SPAM=true&path=C:%5CUsers%5CJean-Marc%5CAppData%5CLocal%5CPanda+Security%5CPanda+Internet+Security+2010%5CAntiSpam>

> >
> >
> ---------------------------------------------------------------------------------------------------
> >
> >
>
> --
> Sincerely,
> N. Wasa
> > _______________________________________________
> Help-octave mailing list
> [hidden email]
> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
>


--------------------------------------
2010 FIFA World Cup News [Yahoo!Sports/sportsnavi]
http://pr.mail.yahoo.co.jp/southafrica2010/
_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
nob
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

nob
Now I have finished the uninstalling and reinstalling the Octave,
however the problem is still found...
OK, I'll do more investigation when I have time.
Thank you to Jean and Matsuoka-san.


2010年7月5日14:22 Tatsuro MATSUOKA <[hidden email]>:

> Hello
>
> Hmmmm! You have applied the fixes for the oct2mat and the ginput issue.
>
> Unfortunately I cannot reproduce the issue that you have met.  I have been using the windows XP, which
> you have used.  I have installed octave-3.2.4/mingw32 at least four win XP machine.  After application
> of the fixes for the oct2mat and the ginput to the octave installed, plot problem that you have
> mentioned have not occurred.
>
> Please try uninstall and reinstall the octave. Sometimes this foolish treatment solves the problem on
> windows if you have not tried it yet.
>
> Sorry I cannot give you useful help.
>
> Regards
>
> Tatsuro
>
> --- Nobuhiko WASA wrote:
>
>> I have already applied this oct2mat patch just after install. Also, renaming
>> the older ginput.m file patch has been applied. However the problem is still
>> coming in.
>>
>> After many trials, I got workaround.
>> I have added "ginput(gcf());" at then end of "__plt__.m" file. Then the
>> hang-up problem now disappear. However, some action (hit key or mouse
>> button) is required on plot window just after plotting to make the prompt of
>> Octave window come back.
>>
>> I'm not sure whether this action is appropriate method or not...
>>
>>
>> 2010/7/2 Jean-Marc Boussard <[hidden email]>
>>
>> > The attached message provides a solution which works... This is the
>> > consequence of an apparently famous bug in Octave.
>> >
>> > Jean-Marc BOUSSARD
>> >
>> >
>> >
>> >
>> > Nobuhiko WASA a 将アcrit :
>> >
>> >  As a result of some experiments, I think this problem comes from the
>> >> command of gnuplot and its timing on plot window.
>> >> I did the following script.
>> >> plot(1:10);pause(5);plot(1:10);
>> >>
>> >> When one of plot window command ("m" or "e") is issued during pause,
>> >> hang-up does not happen.
>> >> When no plot window command is issued during pause, then the plot
>> >> window command is issued after the end of 2nd plot(1:10) command,
>> >> hang-up happens.
>> >>
>> >> However, this workaround is very inconvenience...
>> >>
>> >>
>> >> 2010/7/2 nob <[hidden email]>:
>> >>
>> >>
>> >>> I also have same problem on Octave 3.2.4 for XP. It happens always for
>> >>> wxt
>> >>> and windows terminal.
>> >>> The details in case of wxt terminal are as follows;
>> >>> 1. Type "plot(1:10)" on Octave.
>> >>> 2. Plot window is popped up, however no buttons are appeared on the
>> >>> window.
>> >>> 3. The window couldn't be moved for a several seconds.
>> >>> 4. After a several seconds, the window can be moved. However, the
>> >>> contents
>> >>> of the window is wiped out and nothing is displayed.
>> >>> 5. All of built-in command of gnuplot can't be used. No response. Hanged
>> >>> up.
>> >>> 6. Type "plot(1:10)" on Octave again, the plot appears correctly.
>> >>> 7. However, once type the built-in command on plot window (ex. "m" or
>> >>> "e"),
>> >>> no response. Then gnuplot  window is hanged up.
>> >>>
>> >>> - I have applied the patch for some issues ("oct2mat" and "ginput.m"
>> >>> problem)
>> >>> - I have already confirmed that the "gnuplot.exe" in the Octave\bin
>> >>> directory can worked correctly when it is run individualy.
>> >>> - At first, this problem was found on my office PC. However, same
>> >>> phenomena
>> >>> was happened on my private PC. My office one is Dell, and private one is
>> >>> ThinkPad.
>> >>> - On Octave-3.1.5, same phenomena happen. On Octave-3.0.3, no problem
>> >>> found.
>> >>>
>> >>> Please give me any idea to avoid this problem...
>> >>> If you need more information, please let me know.
>> >>>
>> >>> Regards,
>> >>> Nobuhiko Wasa
>> >>>
>> >>>
>> >>> --
>> >>> View this message in context:
>> >>> http://octave.1599824.n4.nabble.com/plot-window-hangs-tp1681494p2275912.html
>> >>> Sent from the Octave - General mailing list archive at Nabble.com.
>> >>> _______________________________________________
>> >>> Help-octave mailing list
>> >>> [hidden email]
>> >>> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
>> >>>
>> >>>
>> >>>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >
>> > What you met might be the notorious oct2mat issue.
>> > Please see the below
>> >
>> > http://wiki.octave.org/wiki.pl?OctaveForWindows
>> > 1. Standalone ports
>> >  1.1. Octave 3.2.4 for Windows MinGW32
>> >  Additional important topics found after the release:
>> >
>> > [I should acknowledge that this reply is a copy-paste of a previous list
>> > email].
>> >
>> > On Sun, Jun 20, 2010 at 6:28 PM, Jmarc B. <[hidden email]>wrote:
>> >
>> >> I have just the same error with Window7 : the function PLOT works well,
>> >> but do not produce any new window, as indicated on screen image 1 : . Then,
>> >> I issue a PRINT command : the graphic windows opens... and freeze (with the
>> >> "not responding" message from Windows : see image 2 below).. The file with
>> >> the z.png is correctly created in response to PRINT (Z.PNG'). GNUPLOT
>> >> works perfectly, executing demos... (the demos are coming from the
>> >> distribution, but I use the GNUPLOT.EXE in the OCTAVE directory) Any
>> >> solution ?
>> >> ------------------------------
>> >> View this message in context: Re: Plot window
>> freezes<http://octave.1599824.n4.nabble.com/Plot-window-freezes-tp1638002p2261807.html>
>> >> Sent from the Octave - General mailing list
>> archive<http://octave.1599824.n4.nabble.com/Octave-General-f1599825.html>at Nabble.com.
>> >>
>> >> _______________________________________________
>> >> Help-octave mailing list
>> >> [hidden email]
>> >> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
>> >>
>> >>
>> >
>> >
>> > --
>> > /* andy buckle */
>> >
>> >
>> >
>> >
>> ---------------------------------------------------------------------------------------------------
>> > *Texte ins将アr将ア par Panda IS 2010:*
>> >
>> > S'il s'agit d'un mail ind将アsirable (SPAM), cliquez sur le lien suivant pour
>> > le reclasser : C'est du SPAM
>>
> !<http://localhost:6083/Panda?ID=pav_262&SPAM=true&path=C:%5CUsers%5CJean-Marc%5CAppData%5CLocal%5CPanda+Security%5CPanda+Internet+Security+2010%5CAntiSpam>
>> >
>> >
>> ---------------------------------------------------------------------------------------------------
>> >
>> >
>>
>> --
>> Sincerely,
>> N. Wasa
>> > _______________________________________________
>> Help-octave mailing list
>> [hidden email]
>> https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
>>
>
>
> --------------------------------------
> 2010 FIFA World Cup News [Yahoo!Sports/sportsnavi]
> http://pr.mail.yahoo.co.jp/southafrica2010/
>



--
Sincerely,
N. Wasa

_______________________________________________
Help-octave mailing list
[hidden email]
https://www-old.cae.wisc.edu/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

jianhong
I can confirm this problem. I've found that it could be fixed by adding "pause(x)", where x is a small fraction of a second, at the end of __plt__.m. By the way, I use version 3.0.1.

The interesting thing is that the plot window hanging problem occurs only on one of my four Windows XP boxes. Besides, Gnuplot works fine with Octave 3.0.1 on all my three Ubuntu Linux boxes -- two of them are dual boot with XP.
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

az10sbum
I had what seems to be the same problem on my XP box after I installed 3.2.4.  In my case it was the oct2mat issue discussed above.  Try:

pkg unload oct2mat


That fixed it right up for me.

Dave
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

spacebug
Yes, that is the right solution~!!
Reply | Threaded
Open this post in threaded view
|

Re: plot window hangs

nvk255
Yes..  disabling auto load of oct2mat package helps fix the plot window hang
 "pkg rebuild -noauto oct2mat"

When oct2mat package is needed, it can be loaded using
"pkg load oct2mat"