print to emf issue on qt and fltk 4.0 on windows

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

print to emf issue on qt and fltk 4.0 on windows

tmacchant
A simple script


t = 0:0.1:6.3;

plot (t, cos(t), '-;cos(t); ', t, sin(t), '+3;sin(t); ');

print ('test.emf','-demf', '-FArial:12');



gives empty emf file on qt and fltk graphics toolkit.
On gnuplot graphics toolkit create correct emf file.

Is this an know issue?

If not, I will file a bug.

On qt and fltk,
print ('test.eps','-depsc', '-FArial:12');


works fine so that gl2ps works correctly.
File conversion from ps to emf via pstoedit may have issue.

Tatsuro

Reply | Threaded
Open this post in threaded view
|

Re: print to emf issue on qt and fltk 4.0 on windows

Rik-4
On 05/30/2016 05:37 AM, [hidden email] wrote:
Subject:
print to emf issue on qt and fltk 4.0 on windows
From:
Tatsuro MATSUOKA [hidden email]
Date:
05/30/2016 03:05 AM
To:
[hidden email] [hidden email]
List-Post:
[hidden email]
Content-Transfer-Encoding:
quoted-printable
Precedence:
list
MIME-Version:
1.0
Reply-To:
Tatsuro MATSUOKA [hidden email]
Message-ID:
[hidden email]
Content-Type:
text/plain; charset=utf-8
Message:
6

A simple script


t = 0:0.1:6.3;

plot (t, cos(t), '-;cos(t); ', t, sin(t), '+3;sin(t); ');

print ('test.emf','-demf', '-FArial:12');



gives empty emf file on qt and fltk graphics toolkit.
On gnuplot graphics toolkit create correct emf file.

Is this an know issue?

Yes.  See bug #37053 (https://savannah.gnu.org/bugs/?func=detailitem&item_id=37053).  There seems to be something wrong with the fig2dev.exe that MXE octave creates.

--Rik

Reply | Threaded
Open this post in threaded view
|

Re: print to emf issue on qt and fltk 4.0 on windows

tmacchant
----- Original Message -----
>From: Rik >
To: Tatsuro MATSUOKA 

>Cc: octave-maintainers
>Date: 2016/6/1, Wed 06:06
>Subject: Re: print to emf issue on qt and fltk 4.0 on windows
>
>
>On 05/30/2016 05:37 AM, [hidden email] wrote:
>
>Subject:  print to emf issue on qt and fltk 4.0 on windows
>>From:  Tatsuro MATSUOKA 
>>Date:  05/30/2016 03:05 AM
>>To:  "octave-maintainers 
>>List-Post:  
>>Content-Transfer-Encoding:  quoted-printable
>>Precedence:  list
>>MIME-Version:  1.0
>>Reply-To:  Tatsuro MATSUOKA
>>Message-ID:  
>>Content-Type:  text/plain; charset=utf-8
>>Message:  6
>>
>>A simple script t = 0:0.1:6.3; plot (t, cos(t), '-;cos(t); ', t, sin(t), '+3;sin(t); '); print ('test.emf','-demf', '-FArial:12'); gives empty emf file on qt and fltk graphics toolkit.
On gnuplot graphics toolkit create correct emf file. Is this an know issue?
>Yes.  See bug #37053
    (https://savannah.gnu.org/bugs/?func=detailitem&item_id=37053).  There seems to be something wrong with the fig2dev.exe that MXE octave creates.
>
>--Rik
>
>

Thank you for the pointer.
I will make a reply to 
https://savannah.gnu.org/bugs/?func=detailitem&item_id=37053


Tatsuro