problem compiling octave

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

problem compiling octave

theodor abelt
hello i am new to octave and i am having problems installing it (on suse 10.0) first i tried to install it using different rpm-files. but i always got the message that the package didn't include the files. has anybody an idea how to solve this problem? and then i tried to compile the package "octave-forge-2005.06.13" but after i typed in "/bin/octave-forge-2005.06.13> ./configure --with-path=$HOME/octave-forge --prefix=$HOME" i got the following error message: checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed checking for mkoctfile... no configure: WARNING: no mkoctfile found on path ./configure: line 2386: conftest.cc: command not found configure: error: Could not run does anybody have an idea how to solve this problem ? thank you, theodor

Verschicken Sie romantische, coole und witzige Bilder per SMS!   
Jetzt bei WEB.DE FreeMail: http://f.web.de/?mc=021193  
Reply | Threaded
Open this post in threaded view
|

Re: problem compiling octave

Stéfan van der Walt
Hi Theodore

You are trying to install two different things: octave and
octave-forge.  Octave-forge (http://octave.sf.net) is a package that
contains extra toolboxes for octave (http://octave.sf.net).

Before you try to install octave-forge, you should have a running
installation of octave itself.

Stéfan

On Sun, Nov 20, 2005 at 03:07:10PM -0600, theodor abelt wrote:
> hello i am new to octave and i am having problems installing it (on suse 10.0)
> first i tried to install it using different rpm-files. but i always got the
> message that the package didn't include the files. has anybody an idea how to
> solve this problem? and then i tried to compile the package
> "octave-forge-2005.06.13" but after i typed in "/bin/octave-forge-2005.06.13> .



-------------------------------------------------------------
Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:  http://www.octave.org
How to fund new projects:  http://www.octave.org/funding.html
Subscription information:  http://www.octave.org/archive.html
-------------------------------------------------------------