zp2sos error: cplxpair: could not pair all complex numbers

classic Classic list List threaded Threaded
23 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: zp2sos error: cplxpair: could not pair all complex numbers

Ozzy Lash


On Fri, Jan 6, 2017 at 8:04 AM, Nicholas Jankowski <[hidden email]> wrote:
again, no intuitive sense of what I'm looking at, but how important is
the sort order for sos? The values all seem the same out to 1E-14 or
so, but matlab seems to have them sorted differently.

Looking at the documentation for matlab, the zp2sos implementation has an "order" argument that can be either up or down.  The default is up, and in that case it orders the second order sections with the section that has poles furthest from the unit circle first.  I think this ordering is intended to reduce roundoff error, so it might be a good addition to the signal package to allow this argument.



_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: zp2sos error: cplxpair: could not pair all complex numbers

nrjank
In reply to this post by nrjank
On Fri, Jan 6, 2017 at 5:38 AM, Nicholas Jankowski <[hidden email]> wrote:

> On Jan 6, 2017 3:20 AM, "hale812" <[hidden email]> wrote:
>>
>> I would like to start the bug ticket again, but as I told it, I have no
>> access to bug tracking yet. (I've sent a request)
>
> Everyone has access to the bug tracker.
>
> http://bugs.octave.org
>
> Anyone can submit a bug report. A login account is optional. Give it a try.
> Along the top right of the page there's a Bugs menu with Submit New as an
> option. Fill in what you're able and the process starts.
>
> Also, this is a hard stop error that has so far been brought up 2x in 5
> years. It also is in a package, not core octave. This may seem critical to
> you, but if it was a roadblock to more people odds are that it would have
> been heard about more often.
>
> Nick j.

I just saw the bug report submitted, Thanks!  Ozzy, might be worth
posting your changeset. Here's the link.
http://savannah.gnu.org/bugs/?49996

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
Reply | Threaded
Open this post in threaded view
|

Re: zp2sos error: cplxpair: could not pair all complex numbers

Ozzy Lash


On Fri, Jan 6, 2017 at 8:24 PM, Nicholas Jankowski <[hidden email]> wrote:
On Fri, Jan 6, 2017 at 5:38 AM, Nicholas Jankowski <[hidden email]> wrote:
> On Jan 6, 2017 3:20 AM, "hale812" <[hidden email]> wrote:
>>
>> I would like to start the bug ticket again, but as I told it, I have no
>> access to bug tracking yet. (I've sent a request)
>
> Everyone has access to the bug tracker.
>
> http://bugs.octave.org
>
> Anyone can submit a bug report. A login account is optional. Give it a try.
> Along the top right of the page there's a Bugs menu with Submit New as an
> option. Fill in what you're able and the process starts.
>
> Also, this is a hard stop error that has so far been brought up 2x in 5
> years. It also is in a package, not core octave. This may seem critical to
> you, but if it was a roadblock to more people odds are that it would have
> been heard about more often.
>
> Nick j.

I just saw the bug report submitted, Thanks!  Ozzy, might be worth
posting your changeset. Here's the link.
http://savannah.gnu.org/bugs/?49996


Will do, thanks for the pointer.

_______________________________________________
Help-octave mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/help-octave
12